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Utilisation des fiches

Ces fiches sont créées dans un but de formation ou d’autoformation avec la version 3.16.13 du
logiciel.

Le document est réutilisable dans son intégralité, ou fiche par fiche si besoin, selon la licence
Ouverte Etalab.

L’utilisation de ces fiches est simple (orientée utilisateur final), il faut comprendre le sommaire
pour retrouver aisément les manipulations du logiciel.

Les captures d’écran sont issues du logiciel QGIS (GNU — www.qgis.org), associées a des
données personnelles. Symboles utilisés dans les fiches :

e Point d’information ¢»

e Point d’attention &#

*  Manipulation du logiciel &2

E LICENCE OUVERTE

OI OPEN LICENCE

https://www.etalab.gouv.fr/licence-ouverte-open-licence
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0GIS A - Présentation du logiciel

9 QGIS est un logiciel permettant d’exploiter un Systeme d’Information Géographique (SIG).

Un logiciel SIG permet 1’acquisition, le stockage, la mise a jour, la manipulation, et le
traitement de données géographiques. De plus, il permet de faire de la cartographie et de
I’analyse spatiale de fagon précise en fonction de 1’échelle désirée.

Le principe directeur d’un SIG est le suivant : nous avons d’un c6té les données géométriques
et de 'autre les données attributaires, liées a ces données géométriques. Ces données sont
stockées sous format numérique et organisées par couches.

QGIS est distribué sous licence publique générale GNU téléchargeable en francais sur le site
https://www.qgis.org. Il existe d'autres logiciels libres en géomatique tel que GvSIG,
OpenJump, Udig, Grass...

QGIS installe des logiciels tiers qui possedent leur propre licence. Liste des logiciels installés :
1. QGIS
2. Oracle Instant Client
3. MrSID Raster Plugin for GDAL
4. ECW Raster Plugin for GDAL
5. SZIP compression library
D’autres composantes nécessaire a des utilisations spécifiques sont installées telles que :
- GRASS (orienté traitements d’images),
- SAGA (orienté hydrologie, analyse de paysages,
- QT (interfaces graphiques),
Sous licence GNU-GPL
- Python (langage de programmation) sous licence libre Opensource (compatible GPL)

Liste des fiches :

QGIS_A01 - Utilisation et possibilités du logiciel
QGIS_A02 - Environnement du logiciel
QGIS_AO03 - Interface et barres d’outils

QGIS_A04 - Le projet QGZ



OGIS A01 - Utilisation et possibilités du logiciel

9 QGIS est un logiciel SIG (Systeme d’Information Géographique) open source multiplateformes
(Windows, MacOS, Linux).
QGIS Respecte les normes de I’OGC (http://www.opengeospatial.org/).
QGIS a vu ses débuts comme logiciel de cartographie et s’est développé au fil des années pour
s’imposer parmi les logiciels SIG libres les plus performants.

Outre les fonctionnalités de base que 1’on retrouve dans les SIG, comme la saisie, 1’édition, la
consultation, I’interrogation et la mise en forme de données géographiques, on retrouve le
principe des extensions, destinées a ajouter des fonctionnalités a la version de base. L’ utilisateur
a la possibilité de développer ses propres extensions en Python.

Fonctionnalités présentes dans le logiciel par le biais d’extensions ou non (non exhaustives) :

- Exploitation de diverses sources de données telles que les serveurs distants (SQLITE,
MySQL, POSTGIS, ORACLE, ODBC ESRI database... et via les protocoles WM(T)S,
WES(-T), WCS, SFES, GML), les fichiers tabulaires (txt), les bases de données, les
imports et exports (TAB, Dxf, gml, shape, PostGIS, €00, gtx, kml) ...

- Création et édition de données

- Edition des attributs et des objets géographiques (avec gestion topologique telle que le
snaping ou fusion des limites)

- Géoréférencement des fichiers raster au format Tif, JPG, Gif, ASC, IMG, ECW ou
Png...

- Gestion et reprojections (systemes de projection européens et mondiaux intégrés au
logiciel selon les codes EPSG — www.epsg.org)

- Géotraitements (buffer/tampon, intersection, union, jointures spatiales, moyennes...) et
sélections

- Exploitation graphique (histogrammes...) des données attributaires

- Cartographies thématiques (qualitatives ou quantitatives) et production cartographique
(échelle dynamique, nord, 1égende, atlas...)

&’\Voici la liste des 7 modules disponibles par défaut a I’installation de 3.16 (mmqgis et
" QuickMapService n’en font pas partie) :

o) Extensions | Installées (9) H

L Rechercher...

] ¥/|E DB Manager Extensions installées
Installées [ MetaSearch Catalog Client
v & mmaggis Ici vous voyez seulement les extensionsInstallées sur QGIS.

’- Nen installées # Outils GPS Cliguer sur le nom pour voir les détails.

o Installer depi |3 Processing Cliquer sur la case a cocher ou double cliquer sur le nom pouractiverou
bl ] i 1h QuickMapServi désactiverl'extension

2 7p VG pServices .

Iy Vérificateur de géomnétrie Vous pouvez changer l'ordre via le menu contextuel (clic droit).

# Paramétres ¢ Veérificateur de topologie

« Edition hors connexion

Tout mettre & jour Dézinstaller Réinstaller l'extension

Fermer Aide

Les modules précédés d’une encoche sont activés par défaut. Les extensions en ROUGE ont
été mal installées (raisons techniques).
La liste est disponible depuis le menu Extension > Installer/Gérer les extensions :

B Installer/Gérer les extension
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OGIS AQ02 - Environnement du logiciel

QGIS est classiquement composé d’une barre des menus et de barres d’outils variées selon les
besoins.

C’est a partir de la barre des menus que 1’on accede a la plupart des fonctions de QGIS.

|F'rDjet Editer Vue Couche Préférences Extension Vecteur Raster Base de données  Intermet  Traitement 5iu:|e|

Du fait de son historique a orientation cartographique, QGIS possede des menus orientés vers
cette derniere, et des menus complémentaires, traitant plus spécifiquement des SIG.
La plupart des actions de ces menus sont repris sous formes de barres d’outils (cf. fiche A03).

Le menu Projet (nouveau, ouvrir, fermer ou enregistrer des projets...) est classique des
logiciels couramment utilisés. Le projet est le fichier dans lequel les travaux seront enregistrés.
Se reporter a la fiche AO4 pour en savoir plus sur le projet.

Le menu Editer (copier, coller, ajouter ou supprimer...) permet d’accéder a toutes les
fonctionnalités d’édition d’entités géographiques fiche C04 et C05).

Le menu Vue permet d’accéder aux outils de déplacement et d’interrogation des données
géographiques.

Le menu Couche gere la possibilité d’ajouter ou retirer des couches (vecteurs, rasters ou WMS)
du projet, ainsi que les actions classiques de gestion des couches (voir les attributs des couches
ou activer I’édition de couche...).

Le menu Couche, accessible par sa barre d’outils qui reprend les actions, est aussi partiellement
accessible depuis un clic-droit sur le nom de la couche.

Les outils relatifs a Paccés aux informations (cf. barre d’outils Couche> Accéder aux
informations de la fiche A03 si besoins) ont une action sur la couche ACTIVE donc surlignée
en gris !

Le menu Préférences referme 1’accés aux propriétés du projet et celles logiciel en général.
A partir du menu Extension, les extensions du logiciel installées par défaut sur 1’ordinateur

sont listées. Ceci permet notamment de les activer ou les désactiver. Des extensions
supplémentaires sont disponibles, par exemple sur le site https://plugins.qgis.org/plugins/ .

Le menu Vecteur integre des fonctionnalités de géotraitement sur les couches vectorielles, alors
que le menu Raster integre les fonctionnalités de traitement des données sur les rasters.

Les menus Base de données, Internet et Traitements viennent compléter les menus des
versions précédentes ; le premier reprend les diverses extensions (BD Manager, ...) qui offrent
des options différentes de connexions aux bases de données ; le second regroupe les outils liés
a la publication Web des données, alors que Traitements permet d’utiliser la boite a outils de
géotraitements, pour une accessibilité rapide (GRASS, SAGA...).

Le menu Aide renferme des éléments d’aide complémentaires et de 1’ Internet si besoin.



OGIS AQ03 - Interface et barres d’outils

= Inter ace (X ~fabien_guerreiro_cc_by_nc - QGIS . x
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Les barres d’outils reprennent les fonctionnalités présentes dans les menus.
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Barres d’outils d’Extensions : Exemple Grass

Menu (Extensions> Grass)
& Ouvrir le jeu de données

# Nouveau jeu de données

# Fermer le jeu de données

@ Ouvrir les outils GRASS
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OGIS A04 - Le projet 0GZ

La mise en forme des différentes fenétres, 1’ordre de superposition des couches, le choix des
styles pour les objets cartographiques, le positionnement des étiquettes, la l1égende etc. sont
autant d'opérations qu'il est intéressant de sauvegarder pour ne pas avoir a les reproduire a
chaque ouverture de QGIS. Ces éléments ne sont pas enregistrés dans les couches.

Le projet de travail (Projet QGIS) permet de sauvegarder une session de travail (format du
fichier : *.qgz). QGZ est un format compressé qui contient deux fichier (QGD et QGS). Voici
un exemple de fichier *.qgs ouvert avec un éditeur de texte :

[ Citvrvenea: ot D e M e

= —

Fichier Edition Recherche Affichage Encodage Langage Paremétrage Macro  Exécution Compléments Documents 2
%
sHEHRIHRE shile|tel +x BEET =2 @ BEE
" e = eis | = iNodalljs (=] famanqgs\ Pt [

1 <!DOCTYPE ggis PUB p://mrcc.com/qgis.dtd' 'SYSTEM'> -

2 <ggis projectname="" version="2.8.1-Wien"> I |
<title></title> 1=
<layer-tree-group a=wimw t::Checked"” name=""> -4

<customproperties/>
<layer-tree-laver expanded="1" checked="Qt::Checksd"

1
1
id="reg_stat20150413120108524" name="reg_stat"> I\ i Propriétés et Statut
|’
1
1

<customproperties/>
des couches

</layer-tree-layer>
<layer-tres-layer expanded="1" checked="Qt::Checked"
id="dep st£at20150413120108510" name="dep stat">

<customproperties/> =T
</layer-tree-laver>
</layer-tree-group>
<relations/>
<mapcanvas>
<unitsymeters</unitsy
<extent>

<xmin>558341.47967997496016324</ xmin>
<ymin>6608205.5484680923070406</ymin>

1
<xmax>1191939.33681394541636109¢/ xmax> :;_. Etendue de la vue

1

)

<ymax>7107494.48370490408433842</ ymax>

s
i - Parametres de la vue
1</projections> i
ra>
<spatialrefsys>
<proj4>+proj=loc +lat_1=49 +lac_2=44 +lav_0=46.5 +lon 0=3 +x_0=700000
+y_0=6600000 +ellps=GRSE0 +towgs84=0,0,0,0,0,0,0 +units=m +no_defs</proid> |
<srsid>145¢/srsids> '
<srid>2154¢/srid> 1
<authid>EPSG:2154</authid> - 1 3
<description>RGF93 / Lambert-93</descripcions |’ 1 PrQ]eCthn de la vue
<projecticnacronym>lcc</projectionacronym> 1
<ellipsoidacronym>GRS80¢/ellipsoidacronyms I
<geographicflag>false</geagraphicElag> _’ i
</spatialrefsys>
</destinationscs>
36 <layer_coordinate transform info> < K
7 <layer_coordinate transform desthuchId=MEPSG:2154" srcAuthId="EPSG:4326" |
sreDatumTransrorm=r-1 destDatt sform= 1
layerid="dep_stat20150413120108 > l:_j . .
<layer coordinate transform destAuthId="EPSG:2154" srcAuthId="EPSG:4326" | PrQ]eCtlon des couches
srcDatumTransform="-17 descDatumTransform=r-17 1 j
layerid="reg stat20150413120108524%/> !
</layer_coordinate transform info> = I < N .
</aspoaneaes Parametres, d’affichage,
<visibility-presets/> l .
<layer-tree-canvas> = de la legende' .
Norm length: 35470 lines : 690 Ln:38 Col:18 Sel:0 UNIX ANSI 25 UTF-8 INS

Pour enregistrer 1’état d’avancement du travail dans un projet, aller dans le menu Projet
>Sauvegarder le projet.
Le projet ne contient pas de données géographiques. Il renferme une série d'instructions a
QGIS :
* I’emplacement des données utilisées dans la session,
e ]’état des vues (fiche B02),
* les mises en pages (fiche FO1),
* lamise en forme des objets, etc...
Le projet contient des instructions sur les couches a utiliser :
il enregistre le chemin d’acces aux fichiers utilisés, :
relativement au projet), il est indispensable de préserver ces P
couches telles qu’elles sont lors de l'enregistrement | ) i
du projet. Si, une couche est déplacée ou renommée T | o
(sans déplacer tout le dossier du projet et des Pl
couches), QGIS demandera ou est enregistrée la
couche a la prochaine ouverture du projet.
A T’ouverture du logiciel, la partie centrale « vue »,
propose directement [’ouverture des derniers
projets.




OGIS B - Gestion des couches

_ 2 La gestion des couches est essentielle pour bien démarrer 1’apprentissage du logiciel.
- Bien comprendre comment s’organisent les couches les unes par rapport aux autres et comment
s’organise I’articulation entre la donnée géographique et la table attributaire qui lui est associée,
est la base de la compréhension des logiciels SIG.

Une gestion approximative des couches peut générer de nombreux problemes d’analyse,
affichage...

Liste des fiches :

QGIS_BO01 - Ouverture et fermeture d’une couche
QGIS_B02 - Gestion visuelle des couches (propriétés du projet et d’une couche)
QGIS_B03 - Affichage des données attributaires a I’écran

QGIS_B04 - Connaitre et modifier la projection d’une couche



OGIS BO0I - Ouverture et fermeture d’une couche g et

'"" Texte Délimité

Qﬁ GeoPackage

Ouvrir une couche 7, sontis

Pour ajouter une couche, aller dans le menu Couche> Gestionnaire des T Posiresat

sources de données ‘! ou depuis la barre d’outils Couche (fiche A03). n
e Ouvrir une couche locale (ordinateur) type Shp, Tiff... : cf. Ci-dessous = oo
e Quvrir des données tabulaires (txt, csv, dbf), GPS... (fiche GO1) B o
*  Ouvrir une couche distante (Web) type WMS, WES... (fiche GO3) 0

' Couche virtuelle
e Ouvrir une table de base de données PostGIS, SpatiaLite... (fiche G04) é
WMSAMTS

’-E: WCs

L WES
*

MSSQL

Ouvrir une couche locale (vecteur ou raster)
yDans le Gestionnaire des sources de données ‘! choisir I’onglet Ve veeroy

Service de carte ArcGIS
o™ puis Type de source : Fichier, et cliquer sur le bouton Parcourir '
Attentlon au choix de type de fichier/extension (ne seront visibles que les K&

fichiers dont le type est activé) : { Geaoce

Service d'entites ArcGIS

[ Ouvrez une couche de vecteur gérée par 0GR

H Fiegarder dans » | ) couches =l e e B
?

Ouvrir une donnée locale

X stp
r_ETRS89.5hp

e : SIS doud, etc.

codage s -
[ | [ s
Source
Ensemble(s) d darnées vectoriles [[OGR]ESRI Shapefiis ["shp “SHF) =] e |
—ITAGRT ESFI Shapefies shp * GHE) >
A Mapinio Fie (i *tab "MIF *.TAE)
W G Spatal Date Tianster Standard [‘caid dd
GA] 557 Base e (*.000°".000
A Microstalen DGN [.con “D6N)
T GR|VRT -Yilusl Datasouce Tvil “VRT)
- Atlas BNA ["bria * BNA]
GF] Comma Separated Yalue ["csv ".C5¥)
(' GR] Geography Matkup Language [“ gl &t
GR] GPY [ apx " GPX) [
G KML Pkl “KML)
T 5R] GenSON { gerjson * RECUSN)
Ouvrez des donnees raster gerées par GDAL B3| GAJINTERLIS 1 [ sl i “TF “XML "1
F GRINTERUS 3C i i ITF <ML
= o © GRIGMT [owt “6MT)
Flegarder dans : | 53 SCANTOOD_FA_NE_LS3 =] «@ek BR] QL (" saiie "SQLITE] [
= GR] ESFI Personal GeoDatabase [*mdb * M|
| ,} 'I‘L FI5 00T alix Lhl GR]-Plane/Flightaear [pt.dat nav.dat fix dz
| )Fes_oont. a1 GR] Arc/Info ASCII Coverage [%.200 *.E00)
Mes dacuments (S F93_000t HOR R GR] AutoCAD DiSF [“ il “DXF)
gcents el 6] Groconcept [“.gst " txt "GXT “THT) \
o - GR] GeoRiSE [“ami~ XML
2 F93_000L, TFU e fles )
|8Fa3_0001.TIF
s Ly Types de vecteurs
. -
Favris 185230 pom du fickier - [ | Ourir
Fichiers de ype [[GDAL] Tous les fichiers [ L] A | 2 h o l
TGDAL] Wexcel MFF Raster [ hdr ~ HOR] " |[GDAL] Taus les fichiers (71 !_DAL MSWndnwsDev\EE\ndEDErﬂdemB\lm« — Olslr e type
LIVTE o vy Tensin 1.3 bomet (el | GDAL]ERblappes Compressed Wavelets s L] PLIDSK Database File [* pix *PIX]

FARSITE vdLandscaDe File ["lep"LOY |[GDAL] ERMapper JPEG2000 [%ip2 "2k "JP2 4| EDAL PCRaster Faster File [* map L

\ o o N .
EOAL1 Mutsakion Saries g Db | |ISDALIILS P Wop e it PR d f h t
304L] Vitual Raster [ v 1508|551 g Flo Fomel 10 g 8] € 1ichier a aJ outer
S P (GDAL] SATMHBT Fil Fomat (*hat *HGT]
G0AL] Nalional Imagery Transmision Format " § |[GDAL] Levelie heighfied ['ter . TEF)
(60651 ster ProdctFoml TOL fma o | |I506L) Fevagen hegiie e . E7)
304L] Exdas Imagine Imagss (“img *JMG) EDAL] GMT NetCDF Giid Foimal " HI]
04| Groundbased SAF\Apphcalmr\sTestbs | [EDAL] Network Camman Diata Famet (“ne N
el /o ASCI g oo "ASC) (60l 5Pldied vy (* 7“5 I
GDAL] SDTS Raster [ daf * DOF) (GDAL] Raster Makix Forma -rs  RSW]
Radtelte [“salie “SGLITE] EOALIDTED Fitt At [0, a1 *ot: | |[EDAL) EUMETSAT Avchive rlive [ nat “NA,
L SA(GA GIS Binary Grid [“zdal *8DAT) W |[GOAL] Pottable Network Graphics [*png * PN | |[BDAL] et Raster A1 [“rat*RET)
GOALIPEG P - “peg 5 JPEG | 150l oiden ot 581 B .34 58
'I‘ypes de rasters [(Gosiispanese DEM [ mem*MEM) [GDAL] Golden Software Binary Grid (% grd *.GF
C0AL]) Grophis Inetchange Foma -t 61l | [i2DAL Gu\denSwHwele?BlnaW Gid (ard "
(GDAL] Graphics Interchange Foat [.ai Gl | |[GDAL) DRDEC oA
GOAL] Envisat Imags Fomat (r1 “N11 } A Db o i "R N
|[GDAL] %11 Fishtap Fomat [“spm *Ft) ¥ |[GDAL] Ponable Pixmsp Format [*prm " PM] |

GeaSoft Grid Exchange Fomat [ g# " (
Hierarchical Data Fomat Release 5 (h
Northwood Numeric Giid Format .ard?.ts
Northyiood Clasaiied Bid Fomatgro/ 1
L] 4RIC Dighized Rister Graphics " gen |
Standard Raster Product [*img *IMG)
Magellan topa (bl *BL%) | §

i Processor Raster

a3
]
=]
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@Attention : Si le systeme de projection du fichier a ouvrir n’est pas renseigné, ou s’il est
différent de celui de la Vue, sans que la projection a la volée soit activée, il se peut que les
données ne soient pas superposées correctement (se reporter a la fiche B04).

Il est a noter que les rasters n’aiment pas la projection a la volée et nécessitent souvent de
travailler dans un systeme de projection unique et adapté...
Pour ouvrir une image NON géoréférencée, se reporter a la fiche GO2.

) Fermer une couche
Pour fermer une couche présente dans le logiciel, un clic droit sur son nom, puis Supprimer

" & réalise ’action (cela ne supprime pas la couche de I’ordinateur), ou depuis la barre d’outils
Couche (fiche A03).

F. Guerreiro 7
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0OGIS B02 - Gestion visuelle des couches (propriétés du projet et d’une couche)

@ Propriétés du projet

La Vue / Projet est I’organisation visuelle de la superposition des couches.

Propriétés de la fenétre vue Nom de la vue (nom du projet)
(fgbien_guerreiro_cc_by_nc - QG

- o x
Projet Edter Vue &fgrences Extension Vectsur Raster Basededonnées  Internet  Traitg =
1 ] »

NEBERBR OSRA AT,
\B%ﬁ\f‘ﬁ# /BRREE>xE B =aEl==% R 2B
‘L O o ¢ [} 4 rREEC

Explorateur & x
degv#de

G posters -
e Vue
[ os2

v @ WS

Couches & X
CA®T S-BAD

Oe

[ reg_stat

oW

[] DpTS R simpity

Superposition
des couches

‘/ » \. ['Q Taper pour trouver donni[ 2.8782,51.3328 M\uﬂmn e oow
= Q Unités l Echelle

cartographiques  de la vue

Rendu (& ersainisy,

Rotation de la vue
Loupe « zoomer »

q i sans modifier 1’échelle

Projection de la vue

La projection de I[@lue se régle en tout premier lieu, dans le menu Projet >Propriétés du projet
>SCR ou bouton , avant d’ajouter des couches!! QGIS permet de superposer des couches dont
le systéme de projection est différent (lorsqu’il est renseigné).

- La superposition des couches se gere par glissement du nom des couches les uns sur les
autres. L’ordre de visibilité des couches dans la vue est lié a I’ordre des noms.

- Les couches visibles dans la vues sont les couches cochées % .

- Les actions du menu Couche ont une incidence sur la couche surlignée en gris (active).

T Propriétés d’une couche @ ormstion
Un clic droit sur le nom de la couche (ou menu Couche), puis Propriétés édite les
propriétés de couche active :

-3\-:\\ Source

& -
. . . . . & Symbologie
Information : Résumé d’informations sur la couche

Source : Modifier I’alias du nom de la couche. Modifier la projection de la couche €3 Fuquettes

Symbologle Modifier le rendu de la couche, sa transparence ) Baipures
]

Ethuettes Etiqueter les entités en fonction d’un champ présent dans la table attributaire -
Diagrammes : Ajouter des diagrammes en baton / camemberts sur la couche g Vued
Vue 3D : Créer une vue 3D a I’aide d’un champ d’altitude (z) E Champs
Champs : Paramétrer les champs de la table attributaire B Formuire ot
Formulaire d’attributs : Paramétrer les formulaires de saisie (contenus des champs) PR A
Jointures : Créer des liaisons entre attributs de tables (association de couches) Jointure
Stockage auxiliaire : Stocker des données hors de la couche (rotation d’étiquettes...) A st -

. . Stockage auxiliaire
Actions : Lancer des scripts sur la couche .
Infobulles : Information a afficher dans les infobulles B Actions
Rendu : Simplifier le rendu visuel ®

. . N . s . . ’s - Affichage
Variables : Variables d’environnement précises jusqu’a la couche
Métadonnées : Lire les caractéristiques de la couche (emplacement, projection...) & Rendu

Dépendances : Supprimer les caches de couches dépendantes lors de modifications i
Légende : Ajouter des éléments accessibles depuis le panneau couche (ex. : barre de .
transparence) ! Métadonnées
QGIS Server : Informations (titre, résumé, métadonnées) qui seront automatiquement [, “ESEIEES
transmises au serveur QGIS

Numérisation : Vérification de la topologie (superposition, trous ...)

[ . )
— Légende

0GIS Server

“ Murmérisation

F. Guerreiro
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0OGIS B03 - Affichage des données attributaires a I’écran

— Ouvrir la table

h:’ Lien entre les données graphiques et attributaires v ’
= . . ue active
Attributaire Unclic-droitsurle nomde | BHeasrmecsno® e it e st 56 o
A partir du menu Couche la couche pour Montrer EEBLE OB AL SHPP LB 66 mEE
; . dans I'apergu permet y YT LT = o 5 % % @ a
(ou clic-droit sur le nom de d'obtenir une miniature de e Aem D =

la couche ou depuis la barre | ¢endue delacouche

Bote & outis de tratements 8x

. . D Zomrari e ————— ) we
d’outil Couches - Fiche ol T
A03), sélectionner Ouvrir Sl P = 5 s
la table d’attributs pour i

L) Duplicate Layer

afficher les données 3 [y

attributaires d’une couche. oo s L2t

La couche doit étre g e

ACTIVE (surlignée en gris). Slovsama ,
Set CRS » Lent s [ 7.87%6,47.1357 |9

’ . Exporter »
_Sélection :
. . Properties...
o attrlbUtalre Si I'apergu n’est pas affiché : Menu Vue >Panneaux,
Lorsque 1’on sélectionne puis cocher Apergu
une entité sur la vue, a I’aide Remarque : la sélection d’une entité sur

de I’outil Sélection du menu Ialcart_e avec l'outil lselecnon |_rppl|que la o
sélection des données associées dans la i

Couche (O_U depuis la barre table attributaire et inversement. —
d’outils - fiche A03), la ‘

ligne correspondante a I’entité est sélectionnée dans la table (et inversement).

Le nombre d’entités sélectionnées est inscrit dans 1’entéte de la table attributaire.

@) Les outils de la Table attributaire (disponibles depuis une table attributaire est ouverte) :
«  Outils de sélection : a YT B P2 E

Lorsqu’une sélection est activée, on retrouve au-dessus de la table attributaire (respectivement des
boutons ci-dessus): Sélection par expression, Tout sélectionner, Inverser la sélection,
Désélectionner, Sélectionner les entités en utilisant le formulaire, Placer la sélection au début de
la table, Centrer la vue sur la sélection, Centrer et zoomer la vue a 1’échelle de la sélection, Copier
et coller la sélection dans/depuis le presse-papier.

. Outils @édition: /| £ 13 ) 0| fa fo B
Lorsque le « stylo » (premier bouton) est activé (Basculer en mode édition), les boutons suivants
(respectivement, Basculer en mode édition multiple, Sauvegarder les modifications, Actualiser les
modifications, Effacer les entités sélectionnées, Supprimer un champ (une colonne), Ajouter un
champ/ une colonne, et Quvrir la calculatrice de champ) sont alors accessibles.
Le bouton d’actualisation des modifications est utile dans la mesure ou le calcul d’une colonne n’ affiche
pas toujours les nouveaux résultats.
Le clic droit sur une cellule ouvre un menu contextuel (dupliquer, zoom sur I’entité, ouverture du
formulaire de saisie) identique au bouton en bas a droite de la table attributaire. E]

/ Table attributaire - req_stat « Total des entités 13, filtrées: 13, sélectionnées: 0 [17) (27) 3,71 0 el ]

¢ Mise en forme conditionnelle : -
Améliorer I’affichage de certains champs de la table
selon des conditions.

z : X = = &

et | fophl | seebo | Régles de mise n forme conditionnelle
24| Alsace-Champag. 2584552585226

Nom

5l

. 1_ 49| Aquitaine-Limousi_. | 30.44894509918 | test

Exemple : Repérer dans la table les noms de régions a surface - P EE R Conden -
réduite : 5 20 [Bourgogne-franc..|  17.17968250875 } R::::’araa = li‘
Regle sur le champ NOM puis cliquer sur | & NouveleRége m 1538532340 —— =
C?ndition : "surfz}ce" <500 ] e 108834252523 arreien (R = [
Réglage : Choisir les couleurs de texte / fond. Ajouter un ||, sz " e [

symbole. . ‘ i szl (][] (] (5] [mssheriz -
A chaque ouverture de la table, les régions de petite surface seront | |s oG | eI

16.06380430754

notées selon les conditions réglées.

Bl

B

B
14.509663849666 | ‘v‘

(<]

Fait Annuler \ T supprimer |

« Intégrer la table attributaire : l1
Integre la fenétre attributaire au logiciel a la place =
d’une fenétre séparée contenant les attributs.

=
£
g
g
]
I
g
i3




0OGIS B04 - Connaitre et modifier la projection d’une couche

I1 est impératif d’ceuvrer dans un systeéme de projection unique dans la mesure du possible.
Les projections sont exprimées dans QGIS selon leur nom et codes EPSG' correspondants.

9 Afficher ou renseigner la projection (se gere en amont du travail)
- Projection du projet :
Au moment de I’ouverture du projet, donc de la vue, il faut indiquer la projection de ce projet.
Ceci a une influence sur I’affichage de toutes les couches (cf. encadré fiche B02) :

Voici la méme couche, départements de France en Lambert 93, affichée
selon une vue en L93 a gauche, et selon une vue en WGS 84 a droite.

- Projection des couches :
I1 est INDISPENSABLE de connaitre le systéeme de projection des couches (cf. métadonnées).
Par défaut, QGIS applique la projection définie pour la couche. Cependant :
o Lorsque la projection de la couche est différente de celle de la vue, QGIS superpose
les données en transformant les projections « a la volée ».
o Lorsque la projection de la couche n’est pas renseignée, QGIS applique par défaut la
projection de la vue. La projection de la couche se renseigne par clic droit sur le nom
de la couche, puis Définir de SCR d’une couche ou dans les Propriétés de la couche

(cf. fiche B02), puis . dans I’onglet Source.
Le renseignement erroné d’une projection peut induire des erreurs v1s1bles ou non visibles

(calculs de surfaces, croisements de couches...) :
Exemple de la France ci-contre, représentée en NTF - Lambert Centre France, (au lieu de
RGF93-1L93, comme le spécifient ses métadonnées) :

9 Modifier la projection d’une couche (Reprojeter une couche)
Par clic-droit sur le nom de la couche, puis Exporter> Sauvegarder les entités sous...
Une boite de dialogue de copie de la couche (création d’une nouvelle couche) apparait :

) Enregistrer la couche vecterielle sous.. ? x {2 Sélectionneur de systéme de coordonnées de référence ? ®
Sélectionnez le systéme de coordonnées de référence pour le fichier vectoriel. Les données des points seronta
transtormés suivant le systéme de la couche,
Format ESRI Shapefile Ad
Nom de fichier |\ | - @%
—— _ 1 — Rechercher le
Nom de |a couche: Systémes de Coor qorm - L., .
e P code désiré ou partie
SCR EP5G:2154 - RGF93 / Lambert-93 ) * SCR généré (+proj=) Ps=delmbr +no_defs) 03 d
* SCR généré Zlongiat +elips=CPM +no_defs) USER: 10001 u nom
* SCR gégge®+proj=longlat +elps=APL4.9 +na_defs) USER: 100001
A * SCRhéré (+proj=longlat +elips=andrae +no_defs) USER: 100000
Codage UTF-8 ‘ wegha EPSG:4326
0O : ; 93 / Lambert-93 EPSG:2154
Nenregistrer que les entités sélectionnées 4 .
) ] ,‘ < 2 — Sélectionner la
Ajouter les fichiers sauvegardés a la carte e [ Masquer |Es# . .
projection correspondante

P sélectionner les champs a exporter et leurs options d'es R 1D Certifi

RGF93 [CC48 EPSGi3948
RGF93/CC49 EPSG:3949
- . - - 93 [ CC50 EPSG:3950
< >
RGF93 rt-93 EPSG;

¥ Géométrie

OK Annuler Aide < >
SCR de Ia sélection [RGF93 /Lambert-93 |

Emprise: -9.86, 41,15, 10,33, 51.56

Proj4: 4proj=icc Hat_1=49 Hat_2=44 Hat_0=46.5 | — 4
Hon_0=3 4x_0=700000 +y_0=6600000 +ellps=GRS80 &F 3 Vallder
la projection

+ongs4=0,0,0,0,0,0,0 +units=m +no_defs i

NB.: En cas de reprojection [oc [ s [ see

Francaise, les codes IGNF (rechercher dans (1) le code désiré) utilisent la grille centimétrique de 'IGN plus précise
pour la reprojection.

' Codes EPSG utiles a connaitre (http://www.epsg.org/) utilisés dans les logiciels :
2154 : RGF93 Lambert 93 ; 4326 : WGS84 world geographic 2D ;
27571 : NTF Lambert zone I ; 27572 : NTF Lambert zone II ; 27573 : NTF Lambert zone III ; 27574 : NTF Lambert zone IV ;

NB : Le menu Vecteur> Outils de gestion de données offre aussi la possibilité de modifier la projection d’une couche
(Exporter vers une nouvelle projection). Le menu Raster> Projection offre des options de projections pour les rasters.
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P

OGIS C - Structure des couches

La création d’une couche se fait en trois temps.

Il faut d’abord créer la structure de la couche et bien réfléchir aux informations qu’elle doit
contenir. Il faut ensuite créer les entités graphiques. Enfin, il faut remplir la table attributaire en
respectant bien le lien avec la donnée géographique.

Liste des fiches :

QGIS_CO01 - Création d’une couche

QGIS_C02 - Editer des données

QGIS_CO03 - Création de champs attributaires
QGIS_C04 - Création d’objets graphiques

QGIS_CO05 - Modification d’objets graphiques (objets)

QGIS_CO06 - Modification d’objets sémantiques (attributs)

11



0OGIS CO01 - Creéation d’une couche

_aLa création d’une couche doit étre précédée d’une étape de réflexion sur la modélisation du
phénomene a intégrer dans le SIG.

@ Tous les objets d’une méme couche doivent étre du méme type géographique (points OU

~ lignes OU polygones). Chaque objet géographique stocké dans une couche est doté d’un certain
nombre d’attributs (ou champs), qui sont définis lors de la création de la couche, puis
modifiables lors de la modification de la structure de la couche.

¢ Créer une couche
~ A partir du menu Couche, choisir Créer une couche (choisir shapefile par défaut si aucune

base de données ou couche virtuelle n’est utilisée) :

Mouvelle couche GeoPackage... Ctrl+Maj+MN
Mouvelle couche shapefile...

MNouvelle couche Spatialite...

ENSH

Mouvelle couche termporaire en mémaire...,

:\ﬁ

Meouvelle couche virtuelle...

La procédure s’exécute dans cet ordre :

Indiquer I’emplacement et le nom du fichier |-

Indiquer I’encodage? des caracteres (UTF-8 de préférence)

Choisir le type d’entités a créer (point, ligne ou polygone)

Indiquer le systéme de projection

Créer les champs attributaires / colonnes. Le champ est ajouté uniquement avec le
bouton Ajouter a la liste des champs. Il est possible de créer des champs
ultérieurement (cf. fiche C03).

Création d’une couche Enregistrement

Chemin et nom d’enregistrement de la couche <

1 - Entités et Champs

) Mouvelle couche Shapefile ? .
MNom de fichier C(0: Fabien|Temp\QGIS201 dizzy.shp |

Q@ sovelayerss

Type d’entités Codage du fichier uTF8 -
de Ia COUChe Type de géométrie Point b/
dure | yaleurs M
\ EPSG:2154 - RGF93 [ Lambert-83 - |8 — H H '
2 — Projection !
Créer un champ | ik e il 1 X
-Texte 1.2 Nomre décmal \ - i cette
-Entier {enguar [10 | précsen [5 / \ % i B e L A et o ot s St (¥
—Décimal Ajgulee 1 liste des chanps ‘: o o =
-Date SR D Certfié Al
- b longlat +elips. USER: 100002
X, Longueur \ = = . USER:100001
*SCR généré (+proj=longlat 4ellps__USER: 100000
\( {RGro3 Lenberts3 EPSG:i2154 oy
Liste des £ ] 2
. L, Liste des SCR mandiaux [ Masquer les SCR obsolétes
champs ajoutés 2 Dcerre B
-, Supprimer le champ RGFO3/CC48 EPSGi3048
RGF33 /CC4% EPSG:3949
Annuler Jide RGF93 / CCS0 EPSG:3950 L
Projection de la nouvelle couche —
= Par défaut, celle du projet ou renseignée !
= Les actions par défaut se modifient dans Préférences S )
>Options, puis SCR pour les actions sur les projections soner | [

La couche vierge créée est automatiquement ajoutée a la Vue. Son nom est noté dans la table
des matieres de la vue, au-dessus de la derniere couche active (surlignée en gris).
Pour modifier une couche créée, rendre la couche éditable (fiche C02) ; créer ensuite des entités
(fiche C04) et remplir les champs correspondants aux entités créées (fiche C06).

2 ’encodage bien paramétré évite les caracteres (accents, symboles...) remplacés par des caracteres spéciaux.
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OGIS C02 - Editer des données

Toute action de modification sur une couche, que ce soit au niveau de sa structure, des entités
ou de la table attributaire passe impérativement par 1’activation de I’édition.

¢ Editer une couche

" La couche 2 éditer doit étre active, c’est-a-dire surlignée en gris (ACTIVE).
Dans la fenétre Vue, commencer I’édition a partir du menu Couche >Basculer en mode
édition, ou par clic-droit sur le nom de la couche (le clic droit sur la couche assure que la bonne
couche est éditée !).

Le bouton ¥ est alors enclenché | ¥ | (gris plus foncé).
Le nom de la couche ne change pas, les seules modifications sont I’apparition du stylo devant
le nom de la couche et 1’apparition des nceuds dans la vue (si la couche contient des entités !),
comme le présente 1’image ci-dessous :

% ] régions

dep_stat ﬁ

L’édition de la structure, des entités ou de la table attributaire peut alors commencer :
- Dans la vue, les barres d’outils d’édition (outils Créer des entités et Modifier des entités
— cf. fiche AO3) sont maintenant disponibles (ne sont plus grisées).
- Dans la table attributaire de la couche, les outils de la barre d’outils d’édition (cf. fiche
B03), sont aussi accessibles.

. Terminer I’édition
~ Pour arréter I’édition, procéder de la méme facon, menu Couche> Basculer en mode I’édition.
Ceci a pour effet d’arréter I’édition de la couche ACTIVE (surlignée en gris !).

NB.: Lorsque I'on termine 1’édition d’une couche ou d’une table, QGIS demande
automatiquement si les modifications apportées doivent étre enregistrées. Ceci est tres utile en
cas de d’erreur ou de mauvaise manipulation.

I1 est possible de commencer 1’édition de plusieurs couches en méme temps ; il reste cependant
recommandé de ne faire qu'une seule chose a la fois !

La fenétre ci-dessous est un exemple de message lors de la fermeture du logiciel ; certaines
couches ont été modifiées, le logiciel demande si ces modifications sont a conserver :

o Arréter I'édition b

o Voulez-vous enregistrer les modifications pour la couche test_modif_topo 7

Me pas tenir compte | Annuler

'Editer une table attributaire qui ne posséde pas d’entités (dbf, csv...)

" Ouvrir la table a éditer comme une couche vecteur (fiche BO1 si besoin) en spécifiant

|Fichiesdstipe - aifies (1] pour voir un fichier dbf par exemple.

La table est alors accessible dans la liste des couches a gauche de la vue (méme r:f/1 o0
s’il n’existe aucune vue associée a cette table), avec un pictogramme % || Régions
spécifique, comme présenté ci-contre : ) dep_stat
Pour démarrer 1’édition, procéder comme pour une couche vectorielle (ci-dessus).

Depuis la table attributaire, les outils d’édition (cf. fiche B0O3), sont alors accessibles.
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0OGIS C03 - Creation de champs attributaires

Créer un champ / une colonne

~ Commencer I’édition de la couche ou de la table (fiche C02), puis afficher cette table.
Dans la barre d’outil de la Table, choisir 1’outil Ajouter un champ (fiche B0O3) :
Lors de la création du champ, définir tous les éléments constitutifs de ce champ en fonction

— Renommer / supprimer un champ
=~ La modification de la structure de la table
attributaire d’une couche est a éviter : 1’ajout
ou le retrait de champs peut altérer la table. 1
est donc important de vérifier les données

o

de son utilisation ultérieure.

Gestion des champs attributaires
1 — Rendre la table éditable

Le Type : une
Nom du champ iable ¢ bre’
Sans espace ni VarlaA € nomore
caractéres peut etre
—~— speciaux qualitative, donc

Q Ajouter un champ

?/><

2 — Ajouter d [

du champ

-longueur de texte, du nombre,
-nombre de décimales...

unchamp | ——
Commentaire | |
N
Type (fournisseur de donnéec) integer
[longuewr o =
4 — Propriétés
[oc ] amuer

3 — Type de champ
Nombre entier (entier

Nombre entier {entier 64 bit)
Si une longueur de champ est Mombre décimal (réel)
trop courte, la valeur du champ o (chaine de caractéres)
sera tronquée! Date & Heure

créée en ‘texte’
pour des raisons
d’analyse (ex. :
codes
INSEE/numéros de
départements...),
alors que d’autres
seront utilisés en
‘nombre décimal’
pour la symbologie
(surface) ou
‘nombre entier’
(population...).

La Longueur de champ : longueur de 50 inutile pour les données cadrées (INSEE, surface...),
par contre pour des noms de communes, cela semble plus indiqué.
La précision sera fonction de la donnée. Une surface théorique calculée avec le SIG n’implique

pas 8 chiffres apres la virgule !

attributaires apres ce type d’intervention.
L’onglet Champs des Propriétés de la
couche (cf. fiche B02) offre aussi la

possibilité d’insérer / supprimer un champ.

Il est possible de renommer un champ

| (@ Propriétés de la couche - dizzy | Champs sourc,

B (7] 8

x

d  Nom Alas Type Typeudentfié Longuer Précision

123 0 qlonglong Integer64. Bt

abe 1 champ_text Qstring  String 80

10

123 2 champ_enti glonglong Tnteger64

1.2 3 champ_dec double  Real B0l

Commentare  WMS WFS

v e = Anruer Appliquer

Aide

depuis cet onglet en double-cliquant sur son nom, toujours lorsque le mode édition est activé.

Outils complémentaires

Activer I’extension si besoin (cf. fiche AO1).

Des outils de gestion des champs sont disponibles au
travers de la boite a outil de géotraitement. Activer la
boite a outils depuis le menu Traitements >Boite a
outils ;: ¥ Boit= 3 outls | Dans 1’arborescence, déplier
Géotraitements QGIS, puis Table vecteur pour

bénéficier des outils ci-contre.

15 Ajouter un champ & la table des atiributs
90 Ajouter un champ auto4ncréments

5 Ajouter un champ dindex de valeur unique
* Calculatrice de champ

* Calculatrice de champ avancée Python

¢ Refactoriser les champs

92 Supprimer champ(s)

4% Texte vers dédmal
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0OGIS C04 - Creéation d’objets graphiques

La couche sur laquelle il faut créer des entités doit étre présente sur la vue (soit par ajout de
couche -fiche BO1- soit par création d’une nouvelle couche -fiche CO1-).
Rendre la couche éditable (fiche C02) si elle ne I’est pas.

¢ sNumérisation d’une entité

" Attention ! Pour utiliser les outils d’édition sur la couche éditable, la couche concernée doit étre
active (surlignée en gris).
Utiliser la barre d’outils Editer /Créer des entités (fiche A03) pour ajouter des entités. Selon

le type d’entité de la couche, I’outil Créer est différent :
/3

-y
Créer un polygone

Créer une ligne
oo

Créer un point

Sélectionner 1’outil, puis cliquer (un simple clic gauche par nceud ou point) ; pour terminer une
construction (ligne ou polygone), faire un clic-droit (le clic droit ne créé pas de nceud
supplémentaire).

A la fin de la construction, une boite de dialogue apparait automatiquement pour permettre de
renseigner les attributs de 1’entité fraichement créée :

dizzy - Attributs d'entités n
Actions Cliquer sur OK pour confirmer la création, ou sur
id o Annuler pour supprimer la construction si besoin.

champ_enti UL entité créée ; pour la désactiver, aller dans le menu

Préférences> Options, puis, sous 1’onglet

< > Numérisation, cocher Supprimer les fenétres
aner | d’avertissement. ..

|

champ_text [NULL | Cette fenétre est activée automatiquement a chaque
|
|

champ_dec ‘ JULL

w Création d'entité

T NumeErisation = | supprimer la fenétre de saisie des attributs lors de la création de chague nouvelle entits

NB. : Pour créer des entités parfaitement synchrones / superposées (limite commune, noeuds
communs...) se reporter a la topologie de la fiche CO05.

Lorsque la création des entités est terminée, choisir de Terminer I’édition (fiche C02) et
sauvegarder le travail.

(9Suppression d’une entité
~ L’opération consiste a sélectionner une entité sur la couche et a la supprimer. Une fois qu’elle

........

est sélectionnée avec la fleche de sélection =4 de la barre d’outils Couche, appuyer sur I’outil

I pour la supprimer ou touche Suppr du clavier. La couche doit &tre modifiable.
Pour supprimer plusieurs enregistrements, utiliser ctrl pendant la sélection.
La fiche A3 recense tous les outils de numérisation et de numérisation avancée.

15



OGIS C05 - Modification d’objets graphiques (objets)

La modification d’un objet d’une couche requiert que la couche soit modifiable (fiche C02).
Quitter I’éditeur, en enregistrant les modifications une fois le travail fini !

wModiﬁcation

Les outils de création et de modification sont disponibles depuis les barres d’outils Editer (détails
des barres sur la fiche A03). Si elles ne sont pas visibles, elles sont disponibles depuis le menu Vue
>Barres d’outils >Numérisation / Numérisation avancée.

Depuis la barre de création des entités (Numérisation), on peut librement créer, déplacer, dupliquer

ou supprimer des entités (fiche C04).

Depuis la barre de modification des entités (Numérisation avancée), on peut remodeler, créer /

supprimer / fusionner des parties d’entités.

Les entités doivent étre préalablement sélectionnées — fiche D02 si besoin.

défini, perpendiculaire ou parallele).

Nceeuds

L’outil de nceud /& permet de déplacer les nceuds. Un premier clic sur le nceud fait
apparaitre tous les nceuds de I’entité (en rouge). Un clic sur un nceud le fait apparaitre en
bleu.H , un clic-glissé le déplace. Un clic sur un segment sélectionne les deux
neeuds d’extrémité (en bleu) ; un clic-glissé déplace ce segment.

wTopologie

A partir du menu Projet > Options d’accrochage

I\[I L’outil Activer les outils de numérisation avancée affiche le panneau
E5l ci-contre, pour construire des entités selon des angles précis (angle

(environnement de

capture

ci-contre) active

I’accrochage pour la couche actuelle, certaines ou

toutes couches ouvertes.

Choisir la Tolérance

d’accrochage (distance minimum ou la souris
« glissera » automatiquement vers un sommet ou un
segment existant — mettre 20 pixels pour avoir un
apercu). Lors de la saisie d’une nouvelle entité (en rouge lors de 1’édition), a I’approche d’une entité
existante pour laquelle 1’accrochage est activé, la nouvelle entité vient se coller en fonction de la

Mumérisation avancée H
d|314367,934371

[ a|-38,041533

P, x|522391,000000

£ y|s204232,000000

A
el

() Paramétres d'accrochage du projet ? X

Edition topologique

- ErE e

Couche Type Tolérance Unités
O# dizzy sommet
[ ] pPTS_RGF_simplify =ommet 12 pixels

Snapping on Intersection

Eviter les intersections

et 12 pixels

tolérance d’accrochage. Les noeuds superposés sont alors strictement au méme emplacement !

Reégles topologiques et géométriques

Par défaut, il est possible d’établir des regles topologiques pour une couche donnée (clic-droit,
Propriétés, puis onglet Numérisation), telles que supprimer les sommets/points en double,
vérifier la géométrie, ou empécher la superposition d’entités ou les trous lors de 1’édition.

Les deux extensions ci-dessous offrent d’autres options (activer les extensions cf. fiche A01)

Le menu Vecteur > Vérificateur de topologie ouvre le Panneau
vérificateur de topologie ou I’on fixe les régles de superposition.

Exemple : empécher la superposition entre polygones :

1 — Depuis le panneau, appuyer sur paramétres  puis ajouter la régle :
« Ne doit pas se superposer » pour la couche concernée. Créer ensuite un

polygone qui se superpose a un autre.

2 - Dans le panneau, cliquer sur Valider
de topologie s’affichent en rouge dans la vue et dans le
panneau vérificateur.

Le menu Vecteur > Vérificateur de géométries
ouvre la fenétre d’outils supplémentaires
(micropolygones, autointersections, multiparties,
noeeuds dupliqués, trous...)

() Parameétres de régles tepologiques ?®

Régles actuelles

Pas de couche = v | |Pas de couche ~
Panneau vérificateur de topologie

()8
Vo R

ID de l'entité )

Erreur Couche
polygone ne contenant pas de paint DRFTS_RGF_simplify

polygone ne contenant pas de point DPTS_RGF_simplify

polygone ne contenant pas de point DPTS_RGF_simplify
polygone ne contenant pas de point DPTS_RGF_simplify
polygone ne contenant pas de point DFTS_RGF_simplify

7 L R TU R ]

nolvanne ne rontenant nas de nnint DFTS RGE_simnlify

1]
1
2
3
4
Afficher les erreurs 96 erreurs ont £té trouvées
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0OGIS C06 - Modification d’objets sémantiques (attributs)

La modification des données attributaires se fait en concordance avec les objets graphiques qui
leurs sont liés. Lors d’une modification (ou d’une création) des données attributaires, il faut
sélectionner 1’entité sur la carte pour savoir a quelle ligne de la table correspond cette entité
(fiche BO3).

La sélection de I’objet sur la carte se matérialise par un jaune fluo  (couleur modifiable dans
les Propriétés du projet, onglet Général). Dans la table correspondante, la sélection se
remarque surligné (gris foncé ou bleu selon les versions). La sélection de I’objet entraine la
sélection de la ligne dans la table, et inversement.

Modification d’une cellule (pour une ligne ciblée)

Pour mettre une table attributaire a jour, Basculer en mode édition (cf. fiche C02 si besoin),
- Ouvrir la table d’attributs E= (fiche BO3 si besoin) puis changer les données en cliquant sur

un enregistrement a modifier (directement le contenu d’une cellule). Lorsque les manipulations
sont terminées, Terminer 1’édition.

, Calcul d’un champ (méme cellule pour plusieurs lignes simultanément)

¢

<

De méme, Basculer en mode édition, Ouvrir la table d’attributs B

Pour calculer des données d’une colonne entiere / champ il faut sélectionner 1’outil
Calculatrice de champ E=l depuis les outils de la table attributaire (fiche BO3 si besoin). Une
boite de dialogue apparait ou il est possible de calculer les champs selon une expression.

Si des lignes sont sélectionnées, la case permettant de ne mettre a jour que la sélection sera
cochée par défaut !

Calcul de champ attributaire/ colonne

Création d’objets graphiques * - Chnix de |a eolonne 4 mettre 4 inur, ou choix

La numérisation des objets se fait / de création d’une nouvelle colonne

a l’écran sur la couche éditable
Q@ i guencr. << by QG5
e s v

- o x .

T ¢ Calenl nninniement nniir g
as 0] sélection ou toute le entités

["] Mise a jour d'un champ existant

Longueur du NOTTEmmeham

Expression  Editeur de fonction

= 7 5 0 G S e
| ﬁareal | L e Renvoie |3 surface de
el » F CW’;‘SWW"“EE floue I'entité courante. La
n | n Couches surface caleulée par
I Pad I a eZ onctions Coulleur cette fonction respecte
ify : Totel des entités: 96, fitrées: 96, sélectionrlbes: 1 de calculs Date et Heura Z\allfo”ls le p;radmetraget
- R} e = Général T.EI' £: ‘tp,sg‘ . '_;J p'DJE;
¢ svEfh o ) ; et champs| > ceea SFunc clipsoide s G5
ID_GEOFLA CODE_CHF L NOW_CHF L X_CHF_LIEU v Géométrie '
paramétrée pour le
16326,00000000... 001 AGEN| 509 angle_at_vertex projet alors |a surface
. . Sarea sera ellipsoidale, sinon,
5205,000000000... 300 LaRgEHELLE 3797 I CI e allesera calculde salon
5417,000000000... 033 BOURES 6540 azimuth un plan,
5542,000000000... 272 6037
]
Er— ¢ Calcul du champ
33634,00000000... 278 SAINT-BRIELC aas| |
Apercu du résultat 1 5718615287.001953 4 ¥

6735,000000000... 096 GUERET 6126

7186,000000000.. 322 PERIGUELX 5207

Annuler Aide

entités,

Exemple : Calcul des coordonnées X et Y et de la géométrie (périmetre, aire)

Dans la calculatrice de champ, pour calculer Iaire, appuyer sur Géométrie> $Area, il apparait dans la zone de calcul (valable
pour des polygones). Longueur est actif pour des lignes). Choisir Géométrie> $x, et Géométrie> $y pour les coordonnées X
ouY.

Le menu Vecteur > Outils de géométrie> Ajouter les attributs de géométrie permet d’ajouter directement les colonnes de
géométrie (création d’une nouvelle couche)

Les ' (guillemets simples) sont nécessaires pour les valeurs de chaines de caracteres / texte, alors que les nombres (entiers,
décimaux) sont a saisir directement.
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OGIS D - Analyse spatiale

— 2 [ ’analyse spatiale participe au traittement méme des données a partir de requétes spatiales bien
~ définies ou d’actions qui permettent de répondre a un questionnement précis.
Une requéte est une opération qui consiste a interroger une partie de la table de données (ou
table attributaire).
Les requétes peuvent porter aussi bien sur des données attributaires que sur des objets
géographiques.

Liste des fiches :

QGIS_DO01 - Sélection par attributs (requéte attributaire)
QGIS_DO02 - Sélection géographique (requéte géographique)
QGIS_DO03 - Jointure attributaire/ Jointure spatiale
QGIS_D04 - Outils d’analyse spatiale : vecteur

QGIS_DOS - Outils d’analyse spatiale : raster
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0OGIS DO0I - Sélection par attributs (requéte attributaire)

La sélection attributaire se fait sur une seule couche et sur un ou plusieurs attributs de cette
couche (attention, ceci concerne donc la couche active / surlignée en gris) :

& Sélection
La sélection par expression est accessible depuis la table attributaire (fiche BO3 si
besoin) ou de la barre d’outils Couche (fiche A03 si besoin) en cliquant sur le
bouton €1. Attention : avec cette Sélection, on observe le résultat de la sélection en
surbrillance jaune fluo, mais les autres entités sont toujours présentes. Dans ce cas,
il est possible de désélectionner les entités sélectionnées de la couche active avec
I’outil Effacer la sélection "= de la barre d’outils Couche.

La couche concernée par la sélection

= . .
h;jlectton par attributs ost la couche ACTIVE

Requéte finale Opérateurs Aide
q de sélection contextuelle
() Select by Expression - diz 7 x
Expression  Editeur de fon 2
v 1 1 5 |_ Rechercher 1 b e
"champ_text” = 'tt1'| | e “1is e
THo - aractéres Fa du champ

/aleurs pe tuel des
options de chargement d'un échantillan

1 text de ses valeurs.
/_/— enti

dec « | | Le chargement des valeurs de champs
depuis les couches WFS n'est pas géré

avant que la couche ne soit

Choix des i | e et
Champs r— ,
et des e 3 S
fonctions 1

Apercu duré

7z apn .
Aide 4 : Ve rlfl Cat I O n Zoom sur les entité — es entités |+ Eermer\
" Sélectionner des entités

Choix des
Valeurs
connues

o Ajouter ala sélection actuelle

L Supprimer de la sélection actuelle

dection courante

5 : Méthode de sélection

Les valeurs en texte sont a saisir entre guillemets simples ('..."), contrairement aux nombres.

And :"vrai" lorsque ses deux arguments (les expressions qu'il relie) sont vrais. Un enregistrement doit donc satisfaire ces deux conditions pour
étre sélectionné.

Or :"vrai" lorsque 1'un au moins de ses arguments (les expressions qu'il relie) ou les deux sont vrais. Un enregistrement ne doit donc satisfaire
qu'une seule de ces deux conditions pour étre sélectionné. Il est aussi sélectionné s'il répond aux deux conditions.

Exemple : Sélectionner les départements qui ont leur chef-lieu dont le X est & moins de 5100m de 1’origine (attribut « X ») et n’appartenant
pas a la Bretagne (attribut « NOM_REGION ») dans la couche ‘deparement.shp’ :

Couche : DEPARTEMENT.SHP (a activer en gras dans la vue)

Criteres (requéte) : X <= 5097 AND NOM_REGION !='BRETAGNE'

X et NOM_REGION (noms des colonnes) sont a sélectionner dans le menu champs, <=, = et AND dans les Opérateurs. 5097 et
'BRETAGNE' peuvent étre saisis directement dans Valeurs connues.

¢ 3 Exporter la sélection

" Veérifier que la couche sur laquelle la sélection est réalisée soit bien active (en gras), puis choisir
le menu Couche> Enregistrer sous... (ou par clic-droit sur le nom de la couche> Exporter).
Sélectionner « N’enregistrer que les entités sélectionnées ». Déterminer le nom de la couche
de sortie (le type de fichier et la projection si besoin).

ey Filtre
Depuis la vue, choisir le menu Couche ou par clic-droit sur le nom de la couche, choisir o
Filtrer. Entrer 1’expression de sélection ; seuls les objets correspondants a la requéte tg@
apparaissent a ’écran ; il est possible d’effacer la sélection a partir du Constructeur de 9

_requéte (filtre) : laisser la partie requéte (Expression de filtrage) vide.
@Tant que le filtre reste actif, le logiciel ne considerera que les entités filtrées ! ‘*’ oo
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OGIS D02 - Sélection géographique (requéte géographique)

.9 Sélection manuelle i
Les outils de sélection géographique sont disponibles par la fleche noire a droite de 1’outil =
(Sélectionner) de la barre d’outils Attributs (fiche A0O3) ; une liste de sélections s’affiche pour la
couche ACTIVE (en gras) :

w

A 1’aide de 1I’outil

jaune.

@Sélection par localisation
Le menu Vecteur> Outils de

recherche, offre  plusieurs
sélections, comme des sélections
aléatoires...

La sélection la plus utilisée est la
Sélection par localisation :

Elle sélectionne des entités d’une couche en fonction
d’entités d’une autre couche. La syntaxe se monte

(ou autre type de sélection), = i:
cliquer sur I’entité a sélectionner (plusieurs sélections
en maintenant Ctrl). L’entité sélectionnée apparait en

Sélectionner I'entité(s)

Sélectionner des entités avec un polygone

L e . .
i%5 Sélectionner des entités 3 main levée

114 Sélectionner des entités selon un rayon

@ sélection Par Localisation

intersecte ] touche
O contient [ chevauche

O égal [ croise

En comparant les entités de

[ estdisjoint [ estaintérie

Couche de poi}

ntités (prédicat géométrique)

ur

Couche de

(- DPTS_RGF_simpify [EPSG:2154] -

comme une simple phrase a lire.

Désélectionner les entités sélectionnées de la couche

active avec ’outil “&.

Exemple ci-contre : un point est sélectionné en jaune : il « intersecte » les polygones.

Run 2 Batch Process.

? X

polygones
2

élection par localisation
1K
Cet aigo

Les requétes possibles sont les suivantes (selon les types de géométries) :

Opérateurs de la requéte spatiale

Contient

B

Croise
' B

Est disjoint

B.

A Pintérieur

Intersecte

Est égal
A

B

-~

+

N

A est la couche de référence, B est la couche dans laquelle on sélectionne

Chevauche

Touche

ligrles et points

A
Croise
Disjoink
Inktersecte
Touche

palygones

& linkérieur
Chevauche
Conkient
Disjoink

Est egal
Intersecte
Touche

Exemple :

Sélectionner les éléments de la couche ‘riviere.shp’ (A), qui intersectent le département du Nord de la couche
‘departement.shp’(B) :
Vous devez, dans un premier temps sélectionner, le département du Nord dans la couche ‘departement.shp’ (B)

(A I’aide d’une sélection simple fiche DO1).

Dans l’interface sélection par localisation, il faut choisir la couche ‘riviere.shp’ (A), puis la couche
‘departement.shp’ (B) (seule la sélection préalable sera prise en compte dans l'opération si ‘Entité(s)
sélectionnée(s) uniquement’ est coché).

F. Guerreiro

Mise a jour : Novembre 2021 — Licence Ouverte Etalab
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OGIS D03 - Jointure attributaire/ Jointure spatiale

3 Jointure attributaire

La jointure de tables est utilisée pour adjoindre des attributs supplémentaires a la table d’une
couche géographique (couche de départ). Pour joindre deux tables, le type des données du
champ joint doit €tre identique entre les tables (nombres, chaines...).

Dans les Propriétés de la couche, depuis 1’onglet Jointure ¢ , ajouter une nouvelle jointure a

’aide du bouton .

Jointure attributaire

2 : Champ de jointure

De la couche jointe

1 : Couche jointe
Possibilité de joindre une
simple table attributaire (DBF)

@ Add Vector Join

Champ dans la couche ciblg

[] Mettre la couche jointe en cache dans la mémaire virtuelie
[[] Créer un index des attributs sur le champ de la jointure

[ Formudaire dynamique
P [J Jointure de table édittable

[ Choisr les champs a joindre

][] Personnalser le préfixe du nom du champ

3 Champ de

jointure
De la couche d’origine

11 est possible de modifier une jointure préalablement réalisée

Champ
de jointure
de méme
nature!

Appliquer Aide

o] e

Joindre le champ : CODE ; 3. Champ ciblé : IDINSEE

!!' Un champ de jointure peut porter un nom différent dans les tables !!

Il est possible de rendre
la jointure édit:g
sélectionner seule

les champs utiles a la
table jointe, appliquer

un préfixe pour
identifier les champs de
jointure  (vide pour
aucun  préfixe), en
cochant les  cases
correspondantes.

Exemple: Vous disposez d’une

couche ‘comm.shp’ - le contour des
communes ; la table attributaire de
cette couche ne contient que le code
INSEE de chaque commune
(nommé IDINSEE).

Vous disposez, d’autre part, d’une
table attributaire ‘comm_attr’ (sans
données graphiques) - le nombre
d’habitants  (attribut  « hab pour
chaque code INSEE; ce dernier
s’intitule CODE dans la table.

1. Joindre la couche comm_attr ; 2.

@Lorsqu’il n’y a pas de correspondance de champ pour la table d’origine, des valeurs nulles

seront attribuées aux champs joints :
Champs de la couche de départ

CODE_REG NOM_REGION

ID_GEOFLA

Champs de la couche jointe

CODE_DEPT MNOM_DERT CODE_CHF

NOM_CHF

FRAMNCHE-CO...
PROVENCE-AL...
CORSE
ILE-DE-FRAMCE
CHAMPAGNE-...

4 Jointure spatiale

Pour opérer une jointure spatiale (selon la superposition
des objets) ouvrir Joindre les attributs par localisation
du menu Vecteur> Outils de gestion de données.
Sélectionner la Couche d’entrée (1) qui contiendra les
objets du Fichier de sortie (4), puis la Couche a joindre

(2) qui contiendra les attributs joints.

. gll est possible de paramétrer le type de requéte (3) de la
~ jointure— détails des requétes sur la fiche D02, et de créer
soit une seule entité, soit plusieurs entités par élément

joint (5).

1
|

1

! ULL| NULL

: LL NULL

76|75
808
2|02

PARIS
ARDENNES

101
105

ISR 404

PARIS--1ER-AR...
CHARLEVILLE-...
LAON

MULL NULL NOLT
NULL NULL NU \

Couche source:

DPTS_RGF_si

Joindre:

dizzy [EPSG:2154)

r we
intersecte [ chevauche
[ contient [ 2 fintérieur
Cestégd  [oose

[ touche

Ds cpprimer les envegstrements quine pewvent &t o

() Joindre Les Attributs Par Localisation

Run as Batch Process.

£ Joindre les attributs par
localisation

[Run in Background| | Fermer




0OGIS D04 - Outils d’analyse spatiale : vecteur

=4

lancer dans les modifications. Les

4 Les outils d’analyse sont nombreux, il convient de réfléchir a la finalité du travail avant de se

outils d’analyses sont dans le menu Vecteur> Outils de

géotraitement :

r Tampaon...

& Couper... Chaque outil est composé d’une interface ou il faut renseigner
¢ E”;:‘""’e convexe.. deux ou trois éléments. Exemple de I’intersection :

I Différence... = s 7 .

@ Rerouper.. 1. Couche en entrée Couche sur laquelle I’ opérateur va agir.

& Intersection... 2. Couche dintersection Couche qui participe a I’opération.

& Différendiation Symétriaue... 3. Intersection Couche résultante de I’opération

' Unign...

' Elimination Des Palygones Sélectionnés...

L’opération se réalise sur des couches ouvertes ou non dans QGIS. Selon I’ outil des options de
paramétrages supplémentaires peuvent étre disponibles.
Si une sélection est active sur une des couches qui entre dans 1’analyse, 1’opérateur réalise
I’analyse uniquement sur celle-ci !

Ci-dessous quelques exemples d’outils les utilisés en SIG, présents dans QGIS :

Exemples d’outils d’analyse (Menu Vecteur> Outils de géotraitement)

Tampon

Intersection

se superposent ou a limite commune

o B¥=

pour assembler uniquement les portions d’entités qui | Fusionne des entités selon une colonne spécifiée

Différence

{oyie

 Union

pour assembler les entités qui se superposent

o

Regri;uper

-

Les outils d’analyse et des outils supplémentaires sont intégrés dans QGIS au travers de la Boite

a outils de traitements.

Activer la boite, depuis le menu Traitements >Boite a outils: & Boit=zoutis . Dans
I’arborescence, déplier pour bénéficier des outils. Activer I’extension si nécessaire (fiche A03).

v (&) Recouvrement de vecteur
‘% Couper
4 Couper avec des lignes
& Différence
ﬂ Différendation symétrique
48t Extraire/découper par étendue
%' Intersection
w* Intersections de lignes

‘ Union

F. Guerreiro
Mise a jour : Novembre 2021 — Licence Ouverte Etala

v () Analyse vectorielle
& Analyse du plus proche voisin

% Compter les points dans les polygones
:03 Coordonnée(s) moyenne(s)

‘§’ Distance au plus proche centre (igne vers centre)
48 Distance au plus proche centre (points)
= Liste les valeurs unigues

‘ Matrice des distances

48 Rejoindre par des lignes (lignes de hub)
ﬁ Somme des longueurs des lignes

7. Statistiques basiques pour les champs
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OGIS D05 - Outils d’analyse spatiale : raster

g) Les outils d’analyse rasters sont centrés sur I’analyse du maillage du territoire (ceci est lié a la
nature du raster) ; il convient de réfléchir a la finalité du travail et de connaitre lesdites analyses
avant de se lancer dans les analyses. Les outils d’analyses sont dans le menu Raster.

_Calculatrice raster

~ Le menu Raster > Calculatrice Raster lance un outil
trés puissant qui permet de paramétrer des opérations

et croiser des rasters.

Exemple : au Kenya, la relation entre 1’évaporation annuelle moyenne (Ey) et
I’altitude est la suivante (Studies of evaporation in Kenya, EAAFRO, Nairobi,

1968) : Ey (mm) = 2422 — (0.109 x altitude (pieds))

En disposant du raster MNT nommé MNT_100M @1 de la zone considérée, il est
aisé de créer le raster des températures a I’aide de la Calculatrice Raster, en

inscrivant I’expression de la calcultatrice raster comme suit :
2422 - (0.019 * "MNT_100M@1")

&9 Analyse d’altitude / élévation

Ombrage

Pents

Exposition

Relief en couleur
Rugosit€ du Terrain (TRI)

Rugosité

Index de Position Topographigue (TPI)

I’ombrage...

(2 Calculatrice Raster ?

Bandes raster Couche de résultat

F93_0001@1 Couche en sortie

L 1

Format en sortie GeoTIFF

Selected layer extent;

595000,00000 4| Max x| 1145000,00000 :

miny  [6530000,00000 2] max Y |7130000,00000 (&

Colornes 5500

4] uones [ss00

SCR en sortie

Ajouter le

résultat au projet

¥ Opérateurs
+ + 2 cos sin tan log10 €
! 2 acos asin atan In )
a > = - <= 2= AND or

Expression de la calculatrice raster

EPSG:2154-RGF93 [Lambert-03 v | |5

2422-(0.01% * "MNT_10061")|

oK Annuler Aide

Les rasters d’altitude (MNT : modele numérique de terrain), permettent
de déterminer directement (par dérivée) la pente,
d’un terrain.

Les outils sont disponibles depuis le menu Raster > Analyse. Ou du
menu Traitement> Boite a outils> GDAL.

I’exposition,

Toutes ces analyses nécessitent un MNT au format raster en entrée.

Les MNT déterminent les points les plus hauts, les plus bas, les sens d’écoulements donc les
bassins versants. L’analyse poussée des MNT est possible au travers du plugin GRASS et de
ses traitements disponibles depuis le menu Traitement> Boite a outils> GRASS.

YInterpolation automatique
L’interpolation permet de générer une donnée continue en raster, a

W Grille (Moyenne Mabile)...

B,  Grille (Métrique Des Données)...
B Grille (Inverse De La Distance A Une Puissance)...

B, Grid (Plus Proche Voisin)...

partir d’'une donnée de relevés ponctuels sur le territoire (température,

altitude, précipitation...).

Les algorithmes d’interpolation proposés par QGIS (ci-contre) sont accessibles depuis le menu
Raster > Analyse >. D’autres méthodes telles que le Spline / krigeage / TIN sont accessibles
depuis le menu Traitement > Boite a outils (Interpolation / GRASS / SAGA).

@ Le choix de la méthode dépend du type de données et de la distribution spatiale des points.

~ SPLINE

IDW

KRIGEAGE

Exemple de trois interpolations :

L'interpolation IDW (Inverse distance weighted) détermine la
valeur des cellules en calculant une moyenne pondérée a partir des
valeurs des points du voisinage. Il est impossible de créer des crétes
ou vallées si les valeurs nécessaires ne sont pas présentes dans la
donnée de départ. Si les données d'entrée sont clairsemées ou
inégales, le résultat obtenu ne sera pas vraiment représentatif.

La méthode d'interpolation Spline consiste a faire passer une ligne
par les points de voisinage tout en minimisant la courbure de la
surface. Le voisinage est défini par les points les plus proches. Cette
méthode est adaptée aux surfaces sur lesquelles les variations sont
peu importantes. La méthode Spline peut donner des résultats
incorrects lorsque les variations sont importantes sur une distance
horizontale courte car elle peut se traduire par une surestimation ou
une sous-estimation de la valeur.

Le krigeage est la premiére méthode a prendre en considération la
corrélation spatiale (appréciation graphique de la variance en
fonction de la distance entre les données). L'intérét d'une telle
méthode est l'estimation des valeurs et le calcul de l'erreur de
prédiction.
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OGIS E - Analyse thematique/Semiologie/Symbologie

@L’analyse thématique met en évidence un ou plusieurs phénomenes de la carte et participe
=~ grandement au rendu final d’une carte. Elle joue un role dans la perception de la carte par les
différents interlocuteurs.
I1 est donc indispensable de prendre du recul pour voir si le rendu de 1I’information est fidele a
ce qui devait étre mis en avant. Il est aussi indispensable que I’information soit claire et non
noyée dans une masse d’informations inutiles.

Liste des fiches :

QGIS_EO01 - Symbologie/ Affichage simple des entités
QGIS_E02 - Analyse thématique/ Affichage avancé des entités

QGIS_EO03 - Etiquetage des entités
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0OGIS EO01 - Symbologie/ Affichage simple des entités

__a» Modifier toutes les entités d’une couche

~ Cette étape est importante lors de la manipulation des données, car elle gere le rendu visuel de la
superposition des couches. C’est dans ces propriétés que I’on peut rendre transparent I’intérieur des

entités d’une couche pour voir les couches du dessous.

Double-cliquer sur la couche ou faites un clic-droit pour afficher les Propriétés de la couche (fiche B02
si besoin — propriétés d’une couche), puis sélectionner 1’onglet Symbologie (1).

S’assurer que le premier bouton de 1’onglet soit sur affichage simple : Symbole unique (2).

Quel que soit le type d’entité (point ligne ou polygone), il est possible de modifier le fond et la couleur

des symboles, a I’aide de la partie Couches de symboles (3).

Changer le fisuré unique de toutes les entités de la couche

(1) style - osr (2) Symbole unique

Remplissa
Simple

(¥ Symbologie
€17 Etiquettes

Diiagrammes

"‘ Vue 30 &

Unité | Milimere
Champs source "
Opadte

E Formulaire d'attri uts Couleur

Jointures

L
ﬂ Stockage auiliz re

| Rendu final | | Transparence

~—— ]

-

IR

Iﬂu%

q

Couleur

— Texture

Symboles dans

~ | |Ourir Iz bibliothégue

~
7] B N O A i3
A k LT
t
R (3) ! Type de symbol Remplisgfe simple -
L"" \ Couleurs Remplissage Bordure EE] (=8
\ Style de remplissage -Ccnt'lnue - @
» Rendu de couche Style de la bordure | ——— Ligne continue Optlons v @
o Style T 1' 2z
¢ R . R . N Style de jointure ¢Ry Oblique > lees au - @
(exemple aiport  arrow  capital  crde  cty  diamond elipse Largeur de bordure | 0,260000 t e d’entité @ Millmitre -
pou.rles X % & o s % ' yp i
pOll’ltS) starz  star3  triangle triangle2 pentagon square  star Dl 0,000000 | | 0000000 e S b

Le type d’options est fonction du type d’entités (polygones, lignes, points)

La transparence générale de la couche se gere a 1’aide d’une v rensu se oucre

barre de progression présente en bas de la boite de dialogue. ***

[ [rr—

En bas de la boite de dialogue, il est possible d’agir sur le Mode de fusion des couches, (éclaircissement

/ assombrissement), pour un meilleur rendu graphique.

Si un champ de la table attributaire contient les valeurs nécessaires a la
caractérisation de la symbologie des entités (couleur de fond, largeur de

bordure...), il est possible de I’appliquer en cliquant sur le symbole LE situéa | swe | etedent (e

coté de I’option concernée.

_ L’ouverture répétée des propriétés de la couche pour « tester »
@ différents affichages de la couche peut désormais s’éviter en
appuyant sur le bouton ouvrir le panneau de style de couche
présent au-dessus de 1’arborescence des couches qui ouvre un
panneau de mise a jour en direct.

F. Guerreiro
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% name (chaine)

Editer name_reg {chaine)
Coller code _reg  (chaing)

Couches n
« L BY'YE-J'_"TQ

. Couche issue de la jointure spatiale

o dizzy

] DPT5 RGF simplify
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OGIS E02 - Analyse thematique/ Affichage avancé des entités

2 L’analyse thématique a pour objectif principal de mettre en forme les données a afficher sur une carte.
Elle répond aux regles principales de la sémiologie graphique. Se reporter a ces regles pour connaitre
les différents types d’analyses et/ou méthodes de classification des données.

Représentations selon les types de données
3 Dans les Propriétés de la couche, sélectionner 1’onglet Symbologie.
"~ Dans la partie supérieure de la boite de dialogue, sélectionner I’analyse thématique = gf::g:fﬂe
(Type de légende) la plus appropriée a I’affichage des données. Se reporter aux i@ ensembke de reghes
regles de la sémiologie graphique pour adapter 1’analyse. Bl ropcement de oot
Utiliser I’affichage Catégorisé sur une palette de couleurs distinctes (!) pour les o Cortedechaleur
valeurs qualitatives et Gradué pour les valeurs quantitatives ordonnées (variables = *°°
continues vers des variables discretes). Les valeurs quantitatives absolues (variables brutes absolues)
seront représentées par un affichage de symboles proportionnels sur leur centroide.
- Carte de chaleur : représenter une densité de points sous forme de raster.
- Ensemble de regles : combiner les regles de représentation.
- Déplacement de points : déplacer 1égerement les points qui se superposent.
- Polygones inversés : appliquer une symbologie a 1’espace non occupé par des polygones.
- Aucun symbole : Aucun symbole ne sera affiché pour la couche.
- [ ediion GRAS5 : Utilisation de la symbologie Grass.

Valeurs quantitatives ordonnées

(1 ) ¥ Proprigtés de la couche - req_stat | Style (B[ | (2)
' S - _— Type d’analyse
Champ de — Colonne FE— | [£] i thY/P i y
Symbole [ Modification.... Cma lque
Classement Format de Egende | %1 - %2 Coupsr Q i [effectrfs . }
i Lanti L
(4) Hethote Sl Ruptures naturelleseg(Jenks)
/ Palette de couleur Ml (=ource] Ecart-type
Couleur de S Jolles nuphres
Classement Vode | Intervalles égaux v Classes|5 |5 Classer (6)
) i Etiquette de
Classement S légende et
des Valeurs Ajouter une dasse Effacer Effacer tout M/ Lier les imites de classe N (3) pI'éClSlOIl
Importation de s -| Nombre de
AT P Rendu de couche
la symbologie - e e e — classes

Aprés un changement de type d’analyse, il est impératif d’appuyer sur le bouton | @&

1l est possible de rentrer les classes manuellement (5).
Remarque : Les couches sont enregistrées en shapefile (*.shp). Les symbologies produites avec Sauvegarder le style sont en *.qml.

@ La classification de données quantitatives n’est pas le fruit du hasard ! L histogramme de répartition des
données offre la visualisation de la fréquence de distribution d’un champ donné avant d’entamer une
classification des données. Les regles générales sont les suivantes :

/- Symétrique : Méthode de la moyenne et de 1’écart-type
]/ /A - Dissymétrique : Effectifs €égaux (quantiles) ou ruptures naturelles
- Uniforme : Amplitude égale (Intervalles égaux)
Frem re—
.9 L’histogramme est disponible depuis I’onglet ©g
~ Histogramme, en milieu de fenétre, en
complément de I’onglet Classes (5). Une
classification (méme manuelle) doit étre justifiée.

3.66902
65.15823

@
o]
=
b
@

1.06681

| H 1 . .

e — — T — T T T T T —
0 2 4 6 8 10

Barres dhistogramme 30 Afficher valeur moyenne Montrer 'écart-type Charger valeurs
Exemple
Pour représenter la densité de population d’une couche de polygones :
Dans la partie haute de 1’onglet Style, sélectionnez Gradué puis Intervalles égaux (ou autre mode de calcul des classes selon répartition de
I’histogramme !). Dans la partiec Colonne, au centre de la boite de dialogue, choisissez le champ DENSITE, puis le nombre de classes. Vous
pouvez changer les couleurs des plages ainsi que la légende qui apparaitra dans la partie droite de la boite de dialogue.
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- Etiquettes

0OGIS E03 - Etiquetage des entites

Dans les propriétés de la couche (fiche B0O2 si besoin — propriétés d’une couche) sélectionner
I’onglet Etiquettes (ou menu Couche> Etiquetage).
S’assurer que 1’étiquetage des entités est actif en sélectionnant en premier lieu « Monter les

étiquettes de cette couche :

= Montrer les étiguettes pour cette couche

-

S’assurer que le champ Etiqueter avec est bien celui qui contient les étiquettes que I’on veut

voir affichées !

Le bouton E..

d’autres champs de la table attributaire.

, en haut de la fenétre permet de paramétrer les options d’étiquetage en fonction

L’étiquetage se parametre en premier lieu par le Champ de I’étiquette (apparait sur la carte
finale), la Taille de police, la Police, la Hauteur et la Couleur.

La mise en page de
I’étiquette (retour a la
ligne...)

La création d’un halo
autour de I’étiquette
(ombrage).

Création d’un fond
d’étiquette et décalage
de I’étiquette pour
éviter les
chevauchements.

Le placement de
I’étiquette par rapport
a entité.

Les niveaux de zoom
pour lesquels les
étiquettes seront

visibles.

Enfin, il est possible d’enregistrer les parametres de 1’étiquetage :

Si un champ de la table attributaire contient les valeurs nécessaires a la

() Propriétés dela couc\e - DPTS_RGF_simplify | Etiquettes

=i Single labels

? X

- | &

EtiqueterGec | abe NOM_DEPT > (1) Champ pour ]’ethuetage ~| €

w Echantillon de texte

A

Lorem Ipsum
v
G Etiquettes arem Ipsum [ %] [:1186839 ~]| Ky |-
be Texte Texte
i Formatage Palice MS Shell Dig 2 ¥ @
B Mibe Tampon . =
L Style Marmal i 4_54'
B . Arrigre-plan )
= ] = = =
J Ombre U L= =" CKET  KEE
— . o
= % Position Taille [10,0000 ] E
J/ Rendu o
Points - &
Couleur . - =
& Opsdité B (000 &
Type de boitier |Aucun changement i @
Espacement  lettre |IJ,EIU[]D B | @
mot |0,0000 He
Mode de fusion |Normal R E
[ Appliquer un texte d'étiquette de substitution
o
N
[P
Style ~ III Annuler Appliquer Aide
Stvle T

caractérisation d’un élément de représentation du texte (couleur de fond,
espacement des caracteres...), il est possible de 1’appliquer en cliquant

sur le symbole = situé a coté de I’option concernée.

— Paramétrage manuel des étiquettes
= 1l est possible de déplacer, retourner, masquer ou paramétrer manuellement chaque étiquette a
I’aide de la barre d’outils Etiquettes (ci-dessous). Le déplacement / paramétrage sera stocké
localement dans le projet en cours.

F. Guerreiro
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® name (chaine)
code_dept  (chaine)
name_reg  (chaine)
code_reg  (chaine)

s %, 5 5

abe]
=

e

o

kd
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o

0GIS _F - Mise en page

La mise en page est I’étape finale du travail. Les étapes de manipulation des données (création,
analyse spatiale), et de représentation de la symbologie, doivent étre terminées pour entamer la
mise en page.

Elle consiste a mettre tous les éléments indispensables a une carte.

La carte doit contenir impérativement :

Une légende, un titre, 1’orientation, 1’échelle, les sources, le nom et la date de réalisation.

Les logos et mentions Iégales ne sont pas superflus, ainsi qu’un texte explicatif pour éviter toute
mauvaise interprétation de la carte produite.

Liste des fiches :

QGIS_F01 - Création d’une mise en page
QGIS_F02 - Création d’une légende
QGIS_F03 - Eléments d’une mise en page

QGIS_F04 - Exportation de la mise en page et Atlas
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OGIS FO0I - Création d’une mise en page

La création d’une mise en page permet d’éditer une carte complete pour I'imprimer ou
I’exporter.

Avant de lancer une mise en page cartographique, s’assurer d’avoir adapté la symbologie et les
étiquettes des couches dans les propriétés de chaque couche (fiches E).

¢y Créer une mise en page
 Lancer une mise en page a partir du
menu Projet> Nouvelle mise en page :

A partir de la fenétre du composeur,
adapter la page (depuis le menu Mise en
page> Parametres de la page, changer
la mise en page de paysage (horizontal)
vers portrait (vertical) si besoin.

Outils pour se déplacer sur la page a
partir de la barre spécifique et du menu

Nouvelle mise en page vierge

Vue: meee
78 N

- Gérer les éléments :

’ Le menu Ajouter un élément permet d’ajouter les éléments de la mise
g Aouter Corte en page (détails de chaque élément fiche FO3) :
& Ajouter Ich ’1 - . , . .
o Les éléments ajoutés depuis ce menu sont des Objets.
o Ajouter Etiquette R . . . . . R .
. Ajouter Ligende Le cceur de carte, a savoir la Vue, s’ajoute en premier lieu a partir de ce
=5 Ajouter Echelle graphigue menu Ajouter un élément > Ajouter une carte " c.

Ajouter Forme 4

o Pour ajouter les éléments indispensables a la carte comme le titre (Texte
jouter Fléche

I Ajouter Noeud de [dlément ¥ 'l'o), I’Orientation . o, ’Echelle =G, la Légende -2 (fiche FO2) ou un
& Aouter HTML logo (Image “%), aller dans Ce menu A jouter un élément et sélectionner
Ajouter Table des attributs l’ltem déSlI‘é.

Les objets ajoutés a la mise en page possedent plusieurs options spécifiques dans 1’onglet
Propriétés de I’objet (a droite du composeur). Les sous-onglets permettent de choisir le fond,
le cadre et la transparence de 1’objet, les éléments présents dans 1’objet....

On supprime un objet sélectionné a 1’aide de la touche Suppr.

" Grouper crl4G
il Dégrouper Clrl-+Maj+G

Le menu Eléments permet d’organiser les objets entre eux :

Remonter ctri+]

* Groupement de plusieurs objets escere sl
. X Amener vers lavant Cirl+Maj+]
*  Ordre de superposition des objets Eroyer vers e it
» Verrouiller la position des objets it
* Aligner les objets entre eux (détail fiche FO3) i Senens ’

Distribuer les ééments 5

Regmensionner »

¢y Gérer les mises en page

7 Lorsque la carte est terminée, aller dans le menu Mise en page, pour Exporter en image, PDF
ou SVG (fiche FO4).

Depuis la fenétre Vue / Projet, ne pas oublier d’Enregistrer le projet au fur et 2 mesure du
travail (fiche AO4 si besoin). Lorsque plusieurs mises en pages sont créées, il est possible de
les retrouver depuis le menu Projet> Mises en page.
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OGIS FO02 - Création d’une légende

wUne commande spécifique existe pour créer une légende décrivant toutes les informations contenues

7~ dans la carte. Menu Ajouter un élément> ¥ Ajouterlégende | hyjg cliquer sur la mise en page pour
P’insérer. Pour cela, il faut bien évidemment se trouver sur une fenétre Composeur (fiche FO1 si
besoin).

QL’aj out d’une 1égende est totalement 1ié a la vue active qui lui est associée.
Légende Une fois la Iégende ajoutée, 1’onglet Propriétés de I’objet associé a cette 1égende

b rroprictés principales = (partie droite du composeur), propose plusieurs sous-onglets cliquables pour

b obietsdeligende —  paramétrer celle-ci : titre de 1égende ; ajouter/supprimer/grouper les éléments de la
P Polces légende, les renommer ; format général et police des éléments (titres et couches) ;
P Colonnes créer la légende en plusieurs colonnes ; changer ’aspect : du fond ou des bordures
P Symbole du cadre de 1égende...

- Création d’une légende 2 — Mettre a jour les
» éléments en
fonction des
modifications de la
carte, ou
réinitialiser toute la

légende

1 - Propriétés de la
légende

LégEﬂdE P Propriétés principales
B reg stat ¥ Objets de Iégende 3 — Sélectionner
B zps1505 I’élément de

légende a
modifier

® couche de points <:>

4 — Réorganiser les
éléments de légende

9 — Créer des
filtres
d’expressions

rieuide lenfie de latlas

) \ N\  8-Afficher
5 — Créer un groupe \ \‘b uniquement les
de couches .- . / \ t

~  couches visibles

7 — Afficher le
nombre d’entités

6 — Renommer
I’élément de la couche

La légende sur la fenétre Carte est dynamique ; elle peut se mettre a jour lors de modifications des
éléments de la couche (nom, figurés...). Il est conseillé de ne créer la légende qu’apres avoir finalisé
tous les éléments nécessaires a la carte.

aLibellés des éléments de légende
Pour gérer durablement les libellés de 1a 1égende, se reporter aux Propriétés (fiche BO2 si besoins) de
la couche concernée. Sous 1’onglet Source, modifier le nom de la couche au besoin. Sous 1’onglet
Symbologie des Propriétés de la couche, modifier les libellés de la symbologie des éléments
(Légende).

@NB. : Les éléments de la légende sont organisés par défaut selon I’ordre d’empilement des couches.

= Celui-ci ne correspond pas toujours aux régles de mise en page d’une 1égende (élément principal de la

carte en premier, regroupement des éléments de la 1égende en fonction de leur nature...).

Diagrammes Légende

Les diagrammes en camembert bénéficient d’une 1égende paramétrable. Depuis
les propriétés de la couche, puis 1’onglet Diagrammes, le sous onglet Légende,
offre la possibilité d’afficher :
- Les éléments qui composent le camembert
- La variation de taille des T —
diagrammes

&f  Attnbuts Légends
J‘r Apparence
! Taile
G:'D Emplacement

42 Options O Symbole de Kgende

Type et quantité d'accompagnement
| Accompagnement
Projet d'établissement
B Recherche
W Autre
< 500
(> 1000

(> 1500
(" 2000

R Montrer les entrées de lEgende des attributs de dizgramme

w X Montrer les entrées de légende de taille de diagramme-/
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pour un affichage de I’échelle en km, il faut un facteur de 1000

OGIS F03 - Eléments d’une mise en page

Ajouter une carte/ vue :

La vue s’ajoute en premier " . Elle est liée dynamiquement a la carte créée dans le projet.

La vue, appelée Carte (lorsqu’elle est insérée dans la mise en page) est paramétrable depuis
I’onglet Propriété de ’objet a droite du composeur (ces propriétés sont associées a 1’objet
sélectionné sur la mise en page) :

[B] Propriétés principales Mise a jour de l’apercu et rendu en temps réel ou non (lors de
P Couches modifications de la vue)

P Emprise Niveau de zoom de la carte

b || Controlled by atlas Echelles de 1’atlas

P Grilles Création d’une grille de repérage sur la carte

b Apercus Créer un apercu (carte de localisation)

P Position et taille ... Gestion du cadre de la carte, de la transparence...

Dans les propriétés principales, il est possible de modifier le SCR de la carte !
Utiliser le SCR. du projet A

Ajouter du texte :

Cliquer sur @ puis sur la carte a ’endroit désiré. Déplacer cet objet i et modifier le texte
(taille, police, habillage, etc.) dans 1’onglet Propriétés de I’objet.

Ajouter une orientation :

Il est possible d’afficher une simple fleche /", ou une image =L (plusieurs modeles de fleches
indiquant le nord sont disponibles dans les images par défaut proposées —si une rotation de la
vue ajoutée a été exercer, penser a le faire aussi pour la fleche nord !)

Ajouter une échelle graphique : Pt d ot
L’échelle graphique £ est paramétrable dans 1’onglet Objet :

1- Choisir la carte associée et I’apparence de 1’échelle

2- Choisir I’unité de 1’échelle qui sera affichée e

3- Choisir le facteur d’unités @ n >
Exemple : les systemes de projection sont en metre ; L ot de lichele 4 z

graphiqus

=

W Soamrits
4- Choisir la largeur d’échelle (taille des segments) g (0 seaments [gauche2 S drotes
e 0,00 unités
Hauteur |3 mm :
< Disposer les objets :
11 est possible de disposer les objets les uns par rapport aux e
autres. Pour cela il faut sélectionner plusieurs objets (a 'aide | Aiener au Centre horizontslement
de la touche Maj enfoncée) puis utiliser les outils de la barre | Alaner 8 Draite
4o | 21 2 Aligner sur le Haut
concernée . ou du menu éléments.
. L Ly == aligner au centre Verticalement
Il est possible de grouper les éléments [, =< ou les _
) @ @ . Aligner sur le Bas
verrouiller .
Remonter crrl+]
Descendre el Les outils classiques d’agencement des objets les uns par rapport aux
Amener vers [avant Ctrl+Mai+]

autres (avancer un élément, le reculer...) sont également disponibles.

Envoyer vers ['arrigre Cirl-+Maj+[

.. hRh B2 .. . . .. .
Deux outils "> ML de redistribution automatique (redistribuer les objets les uns par rapport aux

Disribuer bords Gauches autres pour éviter les superpositions) et de redimensionnement
! Distribuer au Centre automatique (redimensionner un objet par rapport a la forme d’un
Distribuer bords Droits autre objet) sont désormais disponibles. | Redimensionner au plus Etroit
Distribuer les Bords Supérieurs #  Redimensionner au plus Large
Distribuer Centres Verticaux [ Redimensionner au plus Court
Distribuer les Bords Inférieurs © Redimensionner au plus Long

L Redimensionner au Carré
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0OGIS F04 - Exportation de la mise en page et Atlas

format brop %, brap. *BMPY

’ . .o, . .. . Farmat ico (*.ica, *TC00
¢ alorsque la mise en page est terminée, il est possible de I'imprimer (menu  ¢ormat ipeq (*.jpeg. * PEG)

<y

7 Mise en page> Imprimer) ou d’exporter cette mise en page (menu Mise format jpg {*.jpg. *IPG)

en page> Exporter au format PDF ou Exporter au format SVG, ou format pna (*.pna. “PHG)
Format ppr (*.pprm. *PPM)

Exporter comme image). Farmat L (* E*TIF)

Lors de I’export en image, tous les formats ci-contre sont utilisables : Format GifF ¢ Liff, *TIFF)
Format xbr {* b, *XEM)
Farmat xpr (%, xpm. * KPR

Avant I’export final, il est indispensable d’observer la carte en taille adaptée ;] qui donne une
visualisation globale de I’image finale qui sera exportée (ce qui inclut la taille des étiquettes par
exemple).

@Exemple d’impression :

Carte de test d'impression QGIS

Remarques sur I’exemple :

QGIS permet d’insérer plusieurs vues
différentes et de SCR différents sur une carte
(plan de situation...). I faut verrouiller les
cartes déja présentes (onglet Eléments)
lorsqu’une carte est terminée. Cependant, si
une couche doit entrer dans la composition des
deux visualisations mais avec une symbologie,
étiquetage différents, il convient alors de
copier cette couche, afin de pouvoir gérer plus
facilement les vues séparément.

Légende
Points de relevés
o

Remarques sur le format d’export de la carte :
- L’export en PDF : L’installation d’un petit logiciel d’impression en images diverses tel
PDFCreator, disponible gratuitement sur Internet peut contrer ce probleme.
- D’une maniere générale, il est préférable d’exporter en PNG lorsque la carte ne contient
que des vecteurs et en JPG des qu’il y a des images ou des rasters sur la carte.

—  Générer un atlas

P o Depuis la fenétre de composition, aller dans le menu
A Génererun ates Vue >Panneaux > Génération d’atlas s’il n’est pas
w Configuration . aCtiVé.

Coverage layer (.~ DPTS_RGF_simplify v

[] cacher la couche de couverture

Hom dela page <2l | Il est possible de générer un atlas (batteries de cartes

[ Filtrer avec

en fonction d’une couche de polygones).
Indiquer la couche qui servira de découpage et

[] ordonner par

¥ Sortie

Exoreson d e de sorte paramétrer la sortie des fichiers.

‘output_'||$feature

[ expart d'un seul fichier (si possible) . . . .. .
Format despor de mege |png ~ | Au moment de I’'impression, il faut choisir un dossier

de destination au lieu de choisir un nom de fichier.

Exemple : Créer des cartes en fonction des limites de départements. L’atlas génerera autant de
cartes qu’il y a de départements, sur leur emprise respective.
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OGIS G - Intégration de données externes

Liste des fiches :

QGIS_GO1 - Ouverture de données tabulaires (txt, csv, dbf), GPS et autres
QGIS_GO02 - Géoréférencement d’images : Données rasters
QGIS_GO03 - Ouverture de protocoles Internet — WebServices (WMS, WFS...)

QGIS_G04 - Connexion et gestion de bases de données
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OGIS GOI - Ouverture de données tabulaires (txt, csv, dbf), GPS et autres

< 30uvrir ou exporter des données tabulaires ou données vectorielles externes
=11 est possible d’ouvrir de multiples données, qu’elles SOIENE it core osieciy - “TH 8.6 Ten
. . N . Arc/Info Generate (*.gen *.GEN)
vectorielles ou tabulaires a partir du menu Couche> s s rin s

AutoCAD DXF (*.dxf *.DXF)

Gestionnaire de sources de données (fiche BO1). EDIGEQ ("tnf ~.TH)

ESRI GeoDatabase Personnelle (*.mdb *.MDB)
Tous les types de fichiers listés ci-contre sont importables. Rt ine 50 . oo
Les fichiers MapInfo (TAB) ou interchangeables MIF/MID  [omaisiesirts Sy 7+

. . Format Special Use Airspace (*.sua *.5UA)

sont donc accessibles directement. Format Special Use Airspace Opendir (. *TXT)
Format d'échange de données cadastrales de Tchéquie (*.wfk *WFK)
GPS eXchange Format [GPX] (".gpx ™.GPX)

Les données tabulaires sont des données attributaires ; elles coon e comory

N 7 2z . s .« . | GeoPackage (*.gpkg *.GPKG)
ne possedent pas de données géographiques (pas d’entités !).  serss Camiil)
e e1ei s 15 . . . . soconcept (*.gxt "t MGNT “TXT)

QGIS offre la possibilité d’ouvrir directement des fichiers — Secsrehy Marus Language (GhiL ¢.gmiGh)

CSV? ou texte (TXT). Les fichiers s’ouvrent alors tels que [EUST (i mi i T -1

s’ouvrent des couches (fiche BO1). e o
Microstation DGN (*.dgn *.DGN)

Un fichier XLS bien construit peut s’ouvrir directement, —ns-AKs cmi i)

OpenStrestMap (*.0sm *.pbf *.05M *.PBF)
5-57 Base file (~.000 *.000)
comme un DBF' SEG-P1 (*.seg *.segl *.spl *.5EG *.S5EG1 *.5P1)

La table se gere ensuite comme une table attributaire de s i ol o ges -k =0+ soure 08

Scalable Vector Graphics (*.svg *.5V(G) ~SQUTES ~.UB3 5308 *.513)

couche géographique classique. Storage and eXchange Format (s *S¥F)
. . Systematic Organization of Spatial Information [SOSI] (*.s0s *.505)
/ La table est alors accessible dans la liste Teblew S Offce Open ML (o190

des couches a gauche de la vue (mé&me Y0040 Cuko ukosa " UKO KOO

j Valeurs séparées par une virgule (*.csv *.C5V)
5% 7 lignes $’il n’existe aUCUNE VUE ASSOCIEE & CELIE i bimecpsacs oot oot it oy e

. L e e APT.DAT NAV.DAT FIX.DAT AWY.DAT)
table), avec un pictogramme spécifique,
comme présenté ci-contre :

_@Attention : les données tabulaires ou vectorielles externes peuvent étre en lecture seule. Il faut
~ donc enregistrer une copie de ces données pour les rendre modifiables : A partir du menu
Couche> Sauvegarder sous, lorsque la table est active (surlignée).

— 2Données GPS

wDans la plupart des cas les systemes de positionnement par satellites type GPS permettent de récupérer
des fichiers de points au format ASCII (format texte) ou GPX, a partir du menu Couche> Ajouter
une couche vecteur (fiche BO1). Si les données ne sont pas directement transférables au logiciel SIG
I’extension Outils GPS (installée par défaut) du menu Vecteur peut aider.

< 2Acquérir des données géographiques a partir de tables attributaires :

7 Certaines données ne présentent pas d’objets géographiques mais ceux-ci peuvent &tre construits si on
connait leur localisation en X eten Y.
La présence de coordonnées X et Y dans les champs de la table va nous permettre de créer pour
chaque ligne du tableau un point avec les coordonnées correspondantes.
A partir du menu Couche> Gestionnaire de sources de données puis onglet Texte délimité
spécifier les données géographiques (X et Y) d’un fichier TXT ou CSV dans I’onglet Définition
de la géométrie.
Ne pas oublier de spécifier le systeme de projection associé aux coordonnées géographiques !
Astuce : Pour un fichier autre que CSV/TXT, I’ouvrir classiquement, enregistrer une copie de
ce fichier en CSV, puis créer les points a partir du fichier CSV créé.

3 Le fichier CSV est éditable/créable avec un éditeur de texte. La premiére ligne doit contenir les champs des
colonnes, séparés par « ; » (un point-virgule), les lignes suivantes les données, séparées aussi par « ; ».
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0GIS GO2 - Géoréférencement d’images : Données rasters

wOuvrlr P’outil

~ Inutile d’ouvrir I’'image avant de la géoréférencer, utiliser
I’extension (installée par défaut) Géoréférenceur GDAL du

menu Raster> Géoréférencer.

3Ouvrir ’image

Mm@ e r 7 Z: 8
27e UL PR/ 4

Table des ponts de contrdle

Transformation :Non renseigné 4632956752163 _ EPSG:2154

"~ La partie supérieure contiendra alors I’image, alors que la partie inférieure contiendra la Table
des points de controle (points de géoréférencement).

Dans la fenétre Géoréférencer, ouvrir I’'image a géoréférencer (Fichier> Ouvrir raster).

—.Spécifier la projection

(T

7 A T’ouverture de I’image, si la fenétre SCR n’apparait pas, spécifier le systeme de projection
de géoréférencement dans Parametres> Parametres de géoréférencement.

Ajouter des points de calage

" Dans la fenétre Géoréférenceur, pour ajouter un point de | §iss: g sy o om0 @ao omionisponisss
calage, cliquer d’abord sur 1’outil Ajouter un point =
Une nouvelle fenétre s’ouvre, permettant deux types de

géoréférencement.

Type de géoréférencement

L

(=) Enter Map Coordinates

pour rempir les coordonnées du point.

2

il mm s.55), OD (dol o) ou coordonnées projetées

le bouton du crayon et diguez ensuite sur le point correspondant sur le canevas de carte de QGIS

X /Est |

|Y[Nord‘

OK # Depuis le canevas de carte Annuler

Cas 1 : les coordonnées des points a géoréférencer sont connues
Entrez-les manuellement dans X et Y. Les coordonnées « image » (pixels) s’ajoutent dans srcX et srcY
de la partie Table des points de controle ; les nouvelles coordonnées dans dstX et dstY.

Cas 2 : la vue active sera utilisée pour caler I’image

Choisir # Depuislecanevadelacarte 4 Jieu d’entrer manuellement les coordonnées. Le logiciel pointe
alors la vue courante ol il est possible de choisir I’endroit réel auquel correspond le point fraichement
choisi. Les sreX et srcY se remplissent automatiquement avec les coordonnées, dans le systeme de

projection de la vue en question !

Lors du géoréférencement, modifier © & ou supprimer

Les outils de zoom classiques sont disponibles pour se déplacer sur la carte.

< aSpécifier le type de transformation

=

i le placement d’un point est possible.

7 Avant de commencer le géoréférencement, indiquer le type de transformation et le Raster de
sortie dans le menu Parametres> Parametres de transformation.

2 Type de transformation

On utilise une transformation affine lorsque I’image a référencé est dans la méme projection que I’image de référence
(4 points suffisent). On utilise les transformations polynomiales lorsque les déformations sont importantes (cartes
napoléoniennes...). Il faut un minimum de quatre points pour une transformation polynomiale de premier ordre, six
pour une transformation de second ordre et dix pour une transformation de troisiéme ordre.

Remarque : Un grand nombre de points n’améliore pas forcément la qualité du résultat, préférer donc des points
pres de chaque angle de 1’image a référencer et quelques points au centre. Ne jamais aligner les points.

— Enregistrement du géoréférencement

7 Des que 4 points de calage sont créés (non
alignés et éloignés du centre de I’image), le
logiciel calcule le géoréférencement : il
déplace 1égerement les points (dX et dY) et
affiche I’erreur associée (residual).
Lorsque ceux-ci sont acceptables (le plus

faible possible), enregistrer le raster résultant

géoréférencement.

Table des points de contrile

|on,l’ol'f|id| SO | srcY | dstx | dsty

dx[pixels]

els]

residual[pixels]

4

3
z
1
1]

ap

22958.85
1975.06
3169.79
1030.20
1807.28

711.74|709632.75 | 7077351.55
1710.95 | 6820535, 15 | 6993460.50
1786.80 | 762915.69 | 6987156.59
1287.59 | 603254.30 | FO29708.27
313.73 | 667869.36 | 7109659.11

224
-6.14
2,39
4.36
-2.85

d¥[pix

6.17
4.69

-0.41

-3.70

5.59

B.57
773
2.43
5.71
B.27

artir du menu Fichier> Débuter le
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OGIS GO03 - Ouverture de protocoles Internet — WebServices (WMS, WFS...)

(@ Options | Réseau

@Cette page aborde les connexions sur Internet. Si
I’ordinateur est derricre un Proxy, il est
indispensable de paramétrer le Proxy dans QGIS,
depuis le menu Préférences> Options, puis onglet
Réseau, pour afficher la fenétre ci-contre, cocher
Utiliser un proxy pour I’acces Internet, et paramétrer
ce Proxy.
Se rapprocher d’un administrateur réseau si besoin.

Ne

., Général

“.‘6\ Systéme

% SCR

[ Conevsset

Iégende

Em Ouis
cartographiques

R couvleurs

u N i

[

ﬁ" GDAL

Variables

— Les protocoles Internet cartographiques sont des
Qservices qui diffusent (gratuitement ou non), des
cartes et données disponibles au travers du logiciel
SIG.
L’avantage de ces services est de ne pas devoir
stocker les données (souvent trés lourdes) sur
I’ordinateur, et de pouvoir superposer ces services a
des données locales.

& Autnentification

Général

Adresse de recherche WMS [nitp:

Délal d'abandon pour les requétes réseaux (ms) [s0000

Durée par défaut d'expiration du cache des listes de couches WMS (en heures) |24

Délai dexpiration pour les tuiles WMS-C/AWMTS (en heures) [24

Nombre maxmale de tentatives ors derreur de récupération de tule ou dentités [3

User-Agent |Moala/s.0

Paramétres du cache

Conteru  Authentification

Répertoire | [Users| fabien.quer

Taille [kig] [51200

W

=]]

v Utiliser un proxy pour 'accés Internet

servelr mandataire du systéme par défaut

Type de proxy | HttpProxy

Hate [192,168.1.1]

port (8080
Authentification

Configurations D base

® |

Nom dutiisateur [fabien. querreiro

Motdepasse [seseseseses

Attention: les informations d'identification stockées en texte simple dans paramétres
utilisateur.

Convertir en configuration

Exclure les adresses (débutant par)

e e

—QGIS offre la possibilité d’en afficher plusieurs
d’entre eux (WMS, WES ..)).
Pour accéder a ces services, il suffit de :
1- Entrer I’adresse Internet du service selon son type (WES,
2- Choisir les données dont on a besoin
3- Paramétrer le rendu des données

L’ajout d’une couche WMS est accessible directement depuis

WMS...)

le menu Couche> Gestionnaire de

sources de données, ou panneau Explorateur, puis onglet WMS / WMST.

Connexion aux protocoles de services WMS

s de données | WMS/WMTS

e Recherche de serveurs
Supprimer

2 — Choix
disponibl

des données
es sur le serwce

(2 Gestionnaire des sources de données | WMS/WMTS.

Couches  Ordre des couches

geoserver

1---Con ngmmg

Jeude biles  Recherche de serveurs

C oo Ditowens e o s e
E=T @ b rcer une Nouvelle Connedon WiswhTs o Nom Tire Résumé ~
vao GeoServer Web Map Service Web Map Service f.
1 dger_pb otelier  Ateliers pedogogiques Atehers pédagogia
. 3 doer_pb_cfa centres de formation dapprentis _centres de format
/ ‘ Q'; oo - > R iger_pb ¢ 0p!
/ 5 dger_pb_cfppa  cef h R d h
I - 7 daer_pb_epl &t C
B S —— ... 7 #===_ 4 Choix des couches
Authentification - 1 dger_pb_lycee  lyces publics agricoles LycEes agncoles d...

Configurations  De base Encodage de limage

Choisir ou créer une configuration d'authentification

ol

Pas dauthentification ~
Systémes de Ce

@rpne Opnes O Pes O 6F O TIFF

ées de Référence

Format d’image

Les configurations stockent les informations d'identification cryptées dans la
base de données dauthentification QGIS Taile de tuile
Taile d'étape de requéte

Coretis Limite dentite de GetFeaturel

3% virtuelle

WHMS/WHMTS Options RGFS3 [Lambert-53

Entéte HTTP Referer |

DPI-Mode Tout

[ utiiser la légende WIS contextuelle

— ]
Projection =

Info

[ tanorer ladresse Gethap/GetTike signalée

Nom de la couche [centres de formation dapprentis

[ tgnorer adresse GetFeaturelnfo signalée 1 couche sdlectionnée

£ Service de

Ignorer faxe diorientation (WMS 1.3/WMTS,
b & BT Gl carte ArcaIs

[ tnwverser raxe diorientation

[ Transformation lissée

oK Annuler Aide

3 — Format de restitution

Fermer Ajouter Aide

De nombreux services sont accessibles directement dans QGIS ; beaucoup de pages Internet listent ces
services (exemple : https://sigea.educagri.fr/donnees/serveurs-distants-wms/).

Un onglet Recherche de serveurs permet d’interroger des services WMS existants sur le Web.

D’autres services tels que 1’ajout de couche WFS, WCS... sont

accessibles selon la méme procédure

depuis le méme menu : choisir le type de service distant (configurer, connecter) et charger les données.

F. Guerreiro

Mise a jour : Novembre 2021 — Licence Ouverte Etalab
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0GIS G04 - Connexion et gestion de bases de données

analyses de la donnée.

Les bases de données (BDD) sont un avantage certain dans le stockage et I’automatisation des

I1 est possible de se connecter a une BDD locale ou distante ; il s’agit de bien paramétrer la
connexion. QGIS offre la possibilité de se connecter a de nombreuses bases de données
géographiques en lecture et écriture des données (il faut connaitre les parametres de connexion

— a demander a I’administrateur).

PostgreSQL / PostGIS

Connexion a une base de données PostgreSOL / PostGIS

PostGIS est I’extension spatiale de
PostgreSQL.
—— Se connecter et ajouter une table
7 PostGIS se réalise depuis le menu
Couche >Gestionnaire de sources

2 — Choix des données

disponibles la base de données

@ Gestionnaire des sources de données | PostgreSQL

Comm Colonn Type  Type spatial

de données, onglet PostgreSQL.
Exemple de connexion a une base
de données locale existante :

- Nom : choisir un nom

- Hote : localhost

- Port : 5432

- Base de données : postgres

Configrations  De base

Nom dutisateus stage0d

- Nom d’utilisateur : postgres

- Mot de passe : postgres

] e regarder que dans le schéma “publc”

] st e tables sans oéométres

0] Uttiser o table de métadonnées estinées

1 Alow savingloading QGIS projects in the database

[

Ade

Linestring
MuitPoly.
MutPoly.
MuitPoly.
Mitpont
Mpaly... 2

Géo,
Gé
G
Gés
Gés
Géo
Gés
Gé
G
G
G

o

Ajout

Cl

Schéma

Charger

70X

Envegstrer

id deentt. Selectonnd

RRIRRNRNRRNRNRRRRRRE

ter

& primaire

Ade

Projection
Type de géométrie
Colonne de géométrie

SpatiaLite

@ Gestionnaire des sources de

données| Spatialite

Comnecter | | Nouveau

Table
~ agis perf_sandbox_v2.sclite

MULTIPOLYGONE  geometry
MULTIPOLYGONE geometry
MULTIPOLYGOKE  geometry

MULTIPOINT geometry

MULTIPOINT  geometry
MULTIPOLYGONE _geometry
MULTLROLYLIGNE geometry
MULTIPOINT  geometry
MULTIPOLYGONE  geometry
ULTIPOLYGONE _ geometry
ue MULTIPOLYLIGNE geometry
MULTIPOLYGONE geometry

(] ister les tables sans géometries
[ options de recherche

Flver | Metired jourles statstiues | | Fermer Ajouter aide

wres 9

Base déconnectée

SpatiaLite est I'extension spatiale de Sqlite. Contrairement
aun SGBD lourd tel que PostgreSQL / PostGIS, une base
de données SpatiaLite est contenue dans un seul fichier
facilement « portable ».
Depuis le menu Couche > Gestionnaire de sources de
données, onglet SpatiaLite, créer une nouvelle connexion, puis
parcourir les dossiers jusqu’a I’emplacement du fichier (*.sqlite)
L’ensemble des couches disponibles s’affiche.

L’extension « édition hors connexion » (menu Extension pour charger I’extension, menu Bases
de données pour I’utiliser), permet de synchroniser une BDD SpatiaLite embarquée (utile lors
de saisie sur le terrain) a une BDD PostGIS (base centralisée, partagée, administrée ou les droits

d’acces peuvent €tre gérés).

Gestion des tables et bases

Lorsque les bases de données sont connectées
une premiere fois, elles sont toutes accessibles
depuis I’extension DB Manager (installée par
défaut), depuis le menu Bases de données > DB
Manager pour une gestion centralisée et
simplifiée des tables disponibles.
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